summaryrefslogtreecommitdiff
path: root/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild')
-rw-r--r--dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
new file mode 100644
index 000000000000..d8d3f5e48761
--- /dev/null
+++ b/dev-ml/ocaml-sha/ocaml-sha-1.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib vcs-snapshot
+
+DESCRIPTION="A binding for SHA interface code in OCaml"
+HOMEPAGE="https://github.com/vincenthz/ocaml-sha"
+SRC_URI="https://github.com/vincenthz/ocaml-sha/archive/${PN}-v${PV}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README
+}