summaryrefslogtreecommitdiff
path: root/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-19 14:14:16 +0000
commit80c51284f0017d5765c7ae39207be9c58f4bfa17 (patch)
treef870412cb8771b0acdc3b28c70c09545bf034385 /dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
parentfd089c26c06476b291a5255011ee378561c2615d (diff)
gentoo auto-resync : 19:02:2023 - 14:14:15
Diffstat (limited to 'dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild')
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
new file mode 100644
index 000000000000..8351c029f26d
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-7.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pcre-ocaml/ https://github.com/mmottl/pcre-ocaml"
+SRC_URI="https://github.com/mmottl/pcre-ocaml/releases/download/${PV}/pcre-${PV}.tbz -> ${P}.tbz"
+S="${WORKDIR}/pcre-${PV}"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+IUSE="examples +ocamlopt"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~riscv ~x86"
+
+BDEPEND="dev-ml/dune-configurator"
+RDEPEND=">=dev-libs/libpcre-4.5
+ dev-ml/stdio:=
+ >=dev-lang/ocaml-4.12"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dune_src_install pcre
+
+ if use examples ; then
+ dodoc -r examples
+ fi
+}