summaryrefslogtreecommitdiff
path: root/dev-perl/Authen-Radius
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-perl/Authen-Radius
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-perl/Authen-Radius')
-rw-r--r--dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild48
-rw-r--r--dev-perl/Authen-Radius/Manifest5
-rw-r--r--dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch28
-rw-r--r--dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch43
-rw-r--r--dev-perl/Authen-Radius/metadata.xml12
5 files changed, 136 insertions, 0 deletions
diff --git a/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
new file mode 100644
index 000000000000..f95b495f9fd6
--- /dev/null
+++ b/dev-perl/Authen-Radius/Authen-Radius-0.260.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PORTAONE
+DIST_VERSION=0.26
+inherit perl-module
+
+DESCRIPTION="Communicate with a Radius server from Perl"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~sparc x86"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Data-Dumper-1.0.0
+ >=dev-perl/Data-HexDump-0.20.0
+ >=virtual/perl-Digest-MD5-2.200.0
+ >=virtual/perl-IO-1.120.0
+ >=dev-perl/Net-IP-1.260.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.640.0
+ test? (
+ dev-perl/Test-NoWarnings
+ virtual/perl-Test-Simple
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.26-cisco-dictionary.patch
+ "${FILESDIR}"/${PN}-0.26-no-install-db.patch
+)
+
+src_configure() {
+ export OPTIMIZE="$CFLAGS"
+ perl-module_src_configure
+}
+
+src_install() {
+ perl-module_src_install
+
+ # Really want to install these radius dictionaries?
+ insinto /etc/raddb
+ doins raddb/dictionary*
+}
diff --git a/dev-perl/Authen-Radius/Manifest b/dev-perl/Authen-Radius/Manifest
new file mode 100644
index 000000000000..055c4d19781e
--- /dev/null
+++ b/dev-perl/Authen-Radius/Manifest
@@ -0,0 +1,5 @@
+AUX Authen-Radius-0.26-cisco-dictionary.patch 1176 BLAKE2B a090393a57ee39c06345d0969f5c54de30158265fd548fbe88d7dfd40335523c9ef3c9c5d5ae6432796d992c4f19e793544013bbdb7f9c5cc7854a66ae5a15c6 SHA512 f040137ade128614a0f35fe016a58989e3d5bf8fdc2ed20358223fd5ac4792d72edc135e0c1a4335be3f66d38e0120d8d42950266def30b273484ed6bda66b4c
+AUX Authen-Radius-0.26-no-install-db.patch 1234 BLAKE2B 004c2fefaf43efedfcf92bacff4139795a66c06394984f2c5cda14951214d0fdb97a84f4fbe9617b991a052091281037fcfb2592df0a620c4b8090c9365c5eca SHA512 ee947157e5bb02ccb171554d5b83e44482f0fc44b5d2c1e3d3488943baa175a87950999930ea79dd087c731b145ee15bcf394d784cbcabcd73a2f4ef8362b485
+DIST Authen-Radius-0.26.tar.gz 49432 BLAKE2B 05ce64cf463faa1ad1004a659859961d6df24d0651a180603a5a5fc3d672a91f8df521f7d19bbc7b62aa0d63e1ae5b54dec3d46718973ee160f3e7bae5f15d02 SHA512 6779712cd4fdc45115c6e68766ef58c8b1dc9bf3037f3e0e243bc23318d13b09104df5f825b40ce26f7eebe52e6c4887efc8525334f2ab00da23fe76322f0b56
+EBUILD Authen-Radius-0.260.0.ebuild 934 BLAKE2B 371ba89d5fe8e54e8a798a02f647c59c20bf73333b55c86124002703ea6161074af240f64ed1ac1dd8d62d1018e36445f95047a5a8ec003dda35cca70770a766 SHA512 4d4e682dcba02928bcfb0ac57b2bf1cefe34d882855e25d7e1dfe889f882afef5d1cd062477c8514d83d35e55c8784b75b6169160b062827f4a585d261a25be1
+MISC metadata.xml 398 BLAKE2B e4d3554055d85f7488c0b8e71da8792d7e86560ffe3cfd3037caf69e708f777ffc6e9044d76228463b71c82ad1ca85230e1aec637140fdc2ffe3f9042344acbd SHA512 780392f67556558208d30f88e4bb2ea9c58acbeb250bb01df4de7b9d1cc90e6d17634c4447cb7f779fd1748be3c363b280cac716b250a66c7d1cc1dd349a4ece
diff --git a/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch
new file mode 100644
index 000000000000..19d6b0ed9ca1
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-cisco-dictionary.patch
@@ -0,0 +1,28 @@
+From c3955cd5e9232cf891500cdddf96c0f4e336029b Mon Sep 17 00:00:00 2001
+From: Patrick Lauer <patrick@gentoo.org>
+Date: Mon, 29 Oct 2012 21:02:39 +1300
+Subject: Add ISG support to raddb cisco dictionary
+
+---
+ raddb/dictionary.cisco | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/raddb/dictionary.cisco b/raddb/dictionary.cisco
+index 4dadaa3..8d57a03 100644
+--- a/raddb/dictionary.cisco
++++ b/raddb/dictionary.cisco
+@@ -118,3 +118,11 @@ VALUE Cisco-Disconnect-Cause Session-Failed-Security 101
+ VALUE Cisco-Disconnect-Cause Session-End-Callback 102
+ VALUE Cisco-Disconnect-Cause Invalid-Protocol 120
+
++#ISG Support http://www.cisco.com/en/US/docs/ios/12_2sb/isg/coa/guide/isgcaapa.html
++ATTRIBUTE Cisco-Policy-Up 37 string Cisco
++ATTRIBUTE Cisco-Policy-Down 38 string Cisco
++ATTRIBUTE Cisco-SSG-Subscriber-Password 249 string Cisco
++ATTRIBUTE Cisco-SSG-Account-Info 250 string Cisco
++ATTRIBUTE Cisco-SSG-Service-Info 251 string Cisco
++ATTRIBUTE Cisco-SSG-Command-Code 252 string Cisco
++ATTRIBUTE Cisco-SSG-Control-Info 253 string Cisco
+--
+2.15.1
+
diff --git a/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch
new file mode 100644
index 000000000000..746ba993defc
--- /dev/null
+++ b/dev-perl/Authen-Radius/files/Authen-Radius-0.26-no-install-db.patch
@@ -0,0 +1,43 @@
+From 57b9f1a710c2eee1c8f54eb87d164584aa9532ce Mon Sep 17 00:00:00 2001
+From: Torsten Veller <tove@gentoo.org>
+Date: Mon, 5 Nov 2012 01:02:48 +1300
+Subject: Remove automatic radis-db installer code
+
+---
+ MANIFEST | 1 -
+ Makefile.PL | 1 -
+ install-radius-db.PL => install-radius-db.PL.orig | 0
+ 3 files changed, 2 deletions(-)
+ rename install-radius-db.PL => install-radius-db.PL.orig (100%)
+
+diff --git a/MANIFEST b/MANIFEST
+index a8e2801..09913da 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -4,7 +4,6 @@ README
+ LICENSE
+ MANIFEST
+ Radius.pm
+-install-radius-db.PL
+ t/decode.t
+ t/dictionary.t
+ t/digest.t
+diff --git a/Makefile.PL b/Makefile.PL
+index 45653ab..7f1b202 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -4,7 +4,6 @@ use ExtUtils::MakeMaker;
+ WriteMakefile(
+ NAME => 'Authen::Radius',
+ VERSION_FROM => 'Radius.pm', # finds $VERSION
+- PPM_INSTALL_SCRIPT => 'install-radius-db.PL',
+ MIN_PERL_VERSION => "v5.10",
+ BUILD_REQUIRES => {
+ # Support for TEST_REQUIRES
+diff --git a/install-radius-db.PL b/install-radius-db.PL.orig
+similarity index 100%
+rename from install-radius-db.PL
+rename to install-radius-db.PL.orig
+--
+2.15.1
+
diff --git a/dev-perl/Authen-Radius/metadata.xml b/dev-perl/Authen-Radius/metadata.xml
new file mode 100644
index 000000000000..d5df1a58b810
--- /dev/null
+++ b/dev-perl/Authen-Radius/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">Authen-Radius</remote-id>
+ <remote-id type="cpan-module">Authen::Radius</remote-id>
+ </upstream>
+</pkgmetadata>