summaryrefslogtreecommitdiff
path: root/dev-python/IPy/IPy-1.01-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/IPy/IPy-1.01-r1.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/IPy/IPy-1.01-r1.ebuild')
-rw-r--r--dev-python/IPy/IPy-1.01-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/IPy/IPy-1.01-r1.ebuild b/dev-python/IPy/IPy-1.01-r1.ebuild
new file mode 100644
index 000000000000..3e7455c57296
--- /dev/null
+++ b/dev-python/IPy/IPy-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Class and tools for handling of IPv4 and IPv6 addresses and networks"
+HOMEPAGE="
+ https://github.com/autocracy/python-ipy/
+ https://pypi.org/project/IPy/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE="examples"
+
+python_test() {
+ "${EPYTHON}" test/test_IPy.py || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" test_doc.py || die "Doctests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r example/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}