summaryrefslogtreecommitdiff
path: root/dev-python/PyPDF2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/PyPDF2
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/PyPDF2')
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index 828aa1e707af..884092ea35fc 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -1,4 +1,5 @@
AUX PyPDF2-1.26.0-py3-tests.patch 1452 BLAKE2B bdeb36156cf9b6eec975f0b92f85cb6794259081ec8766b316e94efdf90ddf4bd2401fe1954d87e841628aa90b0978e9899f7562c5c15d71c2c271c6e8537894 SHA512 434d1cb0fb934149054d16521ca414291cbb83618de1468a2a9e630e75fddad4c33c3ba254ae00315b2075faad333b9b027625adda3a0cf064df3366989ea399
DIST PyPDF2-1.26.0.tar.gz 77556 BLAKE2B 8ce9b95165a3841154b6e38e24ca5a4db434ceef9c55fbf2d146b379586160cb985948e0feb7aed135f601535d034ef79ddc1af58a670b07ff7d3621907022ec SHA512 7b427f1d099dcd687a718fb8d86e6f677ad45257414c6367e4dfacd8dfef7e3dbe3816027359868764981f36a30721f1731b4c23cbe2f35cfab1c64fb290b034
EBUILD PyPDF2-1.26.0-r1.ebuild 777 BLAKE2B adf18b1f71c39722bb715708394f65e3330ddb2bb8f96924c95c679e65dda73dfc62bd6ce2f2d0b14c5e76a958d5c46cb36ee3860871743d572728b214e2a717 SHA512 eac5ba56728f0550be3307aa444af63319237897958549c9f12648b05688e1774ef306b58d13794df017f560f8b49447e717a517299560e6a218e71ee1bbbd55
+EBUILD PyPDF2-1.26.0-r2.ebuild 782 BLAKE2B 5cee5f1771f368db8ec343052e83637b79cb9d9220ee4fa69e3bb9688dd2a36618976d7bc486afae77b4d2fe071fb6c62c93c0a0b1511dbfa00244a056f22d37 SHA512 b9ed84ab2ddd5935b081f7f1e1a3d8fb4809bebb189219854f5b549aed3a4937ae02e626a1351a9e4a804cca6ce6cc53ba8214a60f8df0c918979fcb02df9fe7
MISC metadata.xml 376 BLAKE2B 7d73355900b976d92f7fdf12ceb2d19d598557a26f624b2db84597d6747f718eb86cdbc2c96e4e68f3f530193a30943d1c49bde748ee49abf3db23f96690d050 SHA512 1614e84a61aff9ca94b7994782bcc85988707f5a0a646d75a7bd9d52802f47c8451d86ed1d38ae0d7915cedf746d8df98edb34559dd5bb278fb4b92cf6bc7a5e
diff --git a/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild b/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild
new file mode 100644
index 000000000000..f58c46912f0d
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-1.26.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="https://pypi.org/project/PyPDF2/ https://github.com/mstamy2/PyPDF2"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/${P}-py3-tests.patch" )
+
+python_test() {
+ "${EPYTHON}" -m unittest Tests.tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r Sample_Code/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}