summaryrefslogtreecommitdiff
path: root/dev-python/authres
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/authres
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/authres')
-rw-r--r--dev-python/authres/Manifest3
-rw-r--r--dev-python/authres/authres-0.800.ebuild21
-rw-r--r--dev-python/authres/metadata.xml19
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/authres/Manifest b/dev-python/authres/Manifest
new file mode 100644
index 000000000000..8b930695c613
--- /dev/null
+++ b/dev-python/authres/Manifest
@@ -0,0 +1,3 @@
+DIST authres-0.800.tar.gz 19863 BLAKE2B 01f9264a78ef5a3ee9fa1db17dd4fc5d1e849a5f297f610ab0bda09f4900bca15e63d71c2312e12b1e6173213d3eef938dae996c7bcc599de496b6c77001de87 SHA512 d9e73309064e396c51ed55394ce505c21869d267922df55b6723cb6b2409282c7827d35d381877b5f08e037042e015d59246603d51219c829df7b81011499fe7
+EBUILD authres-0.800.ebuild 608 BLAKE2B 8fb7945a3289eb94d5eba23d3063e6ca6831922c16fd4715726cd9d97f6564e7b20a9fa1640309ba1b825cbc07e5c206b07a837c657b180d9d45841f5ab97343 SHA512 71d1f8417e6cf37781ed32e16154f7d8ad8f225d71de3b14b91a27b85707e717a14bcf1b6e0c599e28b82c192374c29cfbc9f41fc6470dfff94a68a2e702e40f
+MISC metadata.xml 659 BLAKE2B 96a0bbbd3a801f527d61237bf4de6b1140cdbb316571efbf4934a0398b6f171ea04bb9c80eca90809ba00eb4b8a2bf9806442752d58e5fc2b43e5c7438425762 SHA512 166514ed6b7ff4e3a3acb703da72e72865ef51b067595375f36bc45541483629582828980befba2711d7b7555f571b91c777162a0996ce57f735a0934c4dfb9d
diff --git a/dev-python/authres/authres-0.800.ebuild b/dev-python/authres/authres-0.800.ebuild
new file mode 100644
index 000000000000..1e4d080bd77a
--- /dev/null
+++ b/dev-python/authres/authres-0.800.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Authentication Results Header Module"
+HOMEPAGE="https://launchpad.net/authentication-results-python https://pypi.org/project/authres/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+python_test() {
+ "${PYTHON}" -c "import sys, ${PN}, doctest; f, t = doctest.testfile('${PN}/tests'); \
+ sys.exit(bool(f))" || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/authres/metadata.xml b/dev-python/authres/metadata.xml
new file mode 100644
index 000000000000..3772cef1634f
--- /dev/null
+++ b/dev-python/authres/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ RFC 5451 Authentication-Results Headers generation and parsing for Python.
+ It also supports Authentication Results extensions:
+ RFC 5617 DKIM/ADSP
+ RFC 6008 DKIM signature identification (header.b)
+ RFC 6212 Vouch By Reference (VBR)
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">authres</remote-id>
+ <remote-id type="launchpad">authentication-results-python</remote-id>
+ </upstream>
+</pkgmetadata>