summaryrefslogtreecommitdiff
path: root/dev-python/dbus-python
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-03 09:30:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-03 09:30:56 +0100
commit9f322d80b846d0000268f94422b74c28979e4adf (patch)
tree7d0526672ae719056f1d302b68cde18c11fc3ab3 /dev-python/dbus-python
parenteaef2dddc42323859c2525b466b380620534c051 (diff)
gentoo auto-resync : 03:06:2023 - 09:30:55
Diffstat (limited to 'dev-python/dbus-python')
-rw-r--r--dev-python/dbus-python/Manifest2
-rw-r--r--dev-python/dbus-python/dbus-python-1.3.2.ebuild21
2 files changed, 14 insertions, 9 deletions
diff --git a/dev-python/dbus-python/Manifest b/dev-python/dbus-python/Manifest
index 7719639aea72..0562b9776d4a 100644
--- a/dev-python/dbus-python/Manifest
+++ b/dev-python/dbus-python/Manifest
@@ -1,3 +1,3 @@
DIST dbus-python-1.3.2.tar.gz 605495 BLAKE2B 6c60217b3837d655ab4f833b9f21d8f76eb4129cfeaa26586ef7adc8be8f8c5f03464428ff9f281b2566fb0f89cbb5e4b5618bf7cc961faf9f638d9011874839 SHA512 9b2885c9c2914142c72487f766b1cdd28a255d9f5a87eaf8f4eb420c6e096a77f210ac5a4fac9843c6531974872880cc28b7e45940e198856e984dcc0715519a
-EBUILD dbus-python-1.3.2.ebuild 1930 BLAKE2B cb9c1e2ba7f4a6ecec719343f8f757d1217aca3adab75e145778a9ac6142eed7a37d5cdb0c09bf5d3724707f7630de9b3a64d00888e65f8d56248d9f7c28fbc8 SHA512 910a21a9f45a4fed8c7fc13f584715e46caa9a7e80d62cbc4aec216151d82fe8e62446c0fd0bf246896467ac05c6a9b4b3713abafcf6dfdebc8991724e4db26a
+EBUILD dbus-python-1.3.2.ebuild 1939 BLAKE2B 3acbe76862f5d056f2af52631762dad5b69837180a23d5acb84b0f56b7ddbc64b13c13cbc9f1217cd49987612ba0a88f02782b5330fab963016f5af95e97714a SHA512 4fe4100e5dffbba5ca4b00fe32aa8b88dc73c2dd33d7d495843264760d44d11c912765252c73f96eae04d68a1107fec6315383152d08ed8b43ae9aa6e9a46c55
MISC metadata.xml 404 BLAKE2B 14fb120b562c66c35e57d6686f87d2515d6e7a33e4a3027e2edde743ca533d8be63c8c3c4596de913c86091b2d768c997a1c25282efa657cab08131090cec588 SHA512 7a22b8fccd4715f6d817d528eadff1eaf126158f02113b318a4cf99b5a9bf7a05e67ad0ef1258399a937599bec23cb52f8fb42652948313fb8c8ba63bc5d22b6
diff --git a/dev-python/dbus-python/dbus-python-1.3.2.ebuild b/dev-python/dbus-python/dbus-python-1.3.2.ebuild
index 5065a91958cf..1a653ddb7cd5 100644
--- a/dev-python/dbus-python/dbus-python-1.3.2.ebuild
+++ b/dev-python/dbus-python/dbus-python-1.3.2.ebuild
@@ -3,22 +3,23 @@
EAPI=7
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
inherit autotools python-r1
DESCRIPTION="Python bindings for the D-Bus messagebus"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/DBusBindings/ https://dbus.freedesktop.org/doc/dbus-python/"
+HOMEPAGE="
+ https://www.freedesktop.org/wiki/Software/DBusBindings/
+ https://dbus.freedesktop.org/doc/dbus-python/
+"
SRC_URI="https://dbus.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
IUSE="doc examples test"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
RESTRICT="!test? ( test )"
RDEPEND="${PYTHON_DEPS}
@@ -28,12 +29,16 @@ RDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
BDEPEND="
virtual/pkgconfig
- doc? ( $(python_gen_any_dep '
+ doc? (
+ $(python_gen_any_dep '
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/sphinx-rtd-theme[${PYTHON_USEDEP}]
- ') )
- test? ( dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/tappy[${PYTHON_USEDEP}] )
+ ')
+ )
+ test? (
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/tappy[${PYTHON_USEDEP}]
+ )
"
python_check_deps() {