summaryrefslogtreecommitdiff
path: root/dev-python/distro
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/distro
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/distro')
-rw-r--r--dev-python/distro/Manifest3
-rw-r--r--dev-python/distro/distro-1.0.4.ebuild25
-rw-r--r--dev-python/distro/metadata.xml20
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
new file mode 100644
index 000000000000..46f7972eaa23
--- /dev/null
+++ b/dev-python/distro/Manifest
@@ -0,0 +1,3 @@
+DIST distro-1.0.4.tar.gz 28772 BLAKE2B 1a337c0a5c125b89adbd3173d17390c5cce12c8549a3e7d90d88fd71f53d1b4c7bc3d1fc87f7bec33d7b4b1311539deaa9414b143daf40108b15dd78370450d8 SHA512 466f2e14b169998e3ff7420e12bf270ad9f934962ae92c2d24bdd747897ad66cb348194dd1376b8b53ed298ea02039943c80d9ccc6b8a01c2bd0c6d2be82c7f6
+EBUILD distro-1.0.4.ebuild 584 BLAKE2B a8891d81d850a655e87f3217bc89f7fa8b9f0a49e84f416ab46e050d8d87334a59d4ac3621b29a844ed9dfdcec6cb69a7262d038d0aa4193f0c9174050e0d4d6 SHA512 d201207a85c964cf3e9f611ca57fbf7eab21301d78db413077e3f60ca072633a4c78583584fd740d0a4b186890f409df994913b3056ae535b8aee6ab8a8bf8c3
+MISC metadata.xml 813 BLAKE2B 7ca7237a784e0d321609382bb6427a39584f9ca36047975fc76926628d5b4b5d54543762bcec7a43eacfa91ac056a96d38a0e71a6baed93b18a9849b2563f502 SHA512 2d9fe5a2567f86d987d950a78d68f09ac45b1a50ff02d1f1c2849c381de1a5a2f164fd6850f427650789a0274af974e23c9b8ba7ef3b37c81ad653b3ba85e0b5
diff --git a/dev-python/distro/distro-1.0.4.ebuild b/dev-python/distro/distro-1.0.4.ebuild
new file mode 100644
index 000000000000..5953b7c8d536
--- /dev/null
+++ b/dev-python/distro/distro-1.0.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="http://distro.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RESTRICT="test" # incomplete test resources
+
+python_test() {
+ py.test || die
+}
diff --git a/dev-python/distro/metadata.xml b/dev-python/distro/metadata.xml
new file mode 100644
index 000000000000..ea74de39e0f3
--- /dev/null
+++ b/dev-python/distro/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ distro (for: Linux Distribution) provides information about the
+ Linux distribution it runs on, such as a reliable machine-readable
+ ID, or version information. It is a renewed alternative
+ implementation for Python's original platform.linux_distribution
+ function, but it also provides much more functionality which isn't
+ necessarily Python bound like a command-line interface.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">distro</remote-id>
+ <remote-id type="github">nir0s/distro</remote-id>
+ </upstream>
+</pkgmetadata>