summaryrefslogtreecommitdiff
path: root/dev-python/mechanize
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/mechanize
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/mechanize')
-rw-r--r--dev-python/mechanize/Manifest3
-rw-r--r--dev-python/mechanize/mechanize-0.2.5-r1.ebuild35
-rw-r--r--dev-python/mechanize/metadata.xml21
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/mechanize/Manifest b/dev-python/mechanize/Manifest
new file mode 100644
index 000000000000..5351a0bebe51
--- /dev/null
+++ b/dev-python/mechanize/Manifest
@@ -0,0 +1,3 @@
+DIST mechanize-0.2.5.tar.gz 383918 BLAKE2B c9951f47067798861de0f153e02985c8d00fb4070960993f2ea1c32ee52d6c937af51cd6e3d291273877da0bb9bee2106b92d3518b180ebfd74eafc764136a10 SHA512 23de1d9a5fba63d76fd577889594dacf5412fb2fccb58908a10ab350a81dd16a7a31019d0b4a59a5ed4115320c7e3585c77eef88dcd80a88a9c3c2da3c28fa68
+EBUILD mechanize-0.2.5-r1.ebuild 971 BLAKE2B 302ed76423b10f92a54d567b6a74a58007e4733488bdad23f55db57fa016747b1893b148c0ab06de8dc4cdd00ab4007c571e0611c36bce7df83fc73c49c7cfae SHA512 0c4fb7e5169996ce133d9ceaec506553799b69137f358376d8ac9e059ffd61b52e5aae6cc7fd671eb0ff4b8ae9d4928f47c3e407e03ae2eb35e895d56820fa5b
+MISC metadata.xml 959 BLAKE2B 7e3bc231d201f4b49561f1594301f1d2663744d4a5da0e9f277f2434f80eef016e98e5317016f3e330b1f8daa6a4559db6207720888b99dbb9634c605bcc0472 SHA512 37015b73d1166a75a206306eea97957f23cee6f558bafe54b18c99b7b70b966569a87e9d70466ed50393c1968aa1f7dd884cdf98bd401f274d1e6510d927afa8
diff --git a/dev-python/mechanize/mechanize-0.2.5-r1.ebuild b/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
new file mode 100644
index 000000000000..34eb574b0ce5
--- /dev/null
+++ b/dev-python/mechanize/mechanize-0.2.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Stateful programmatic web browsing in Python"
+HOMEPAGE="http://wwwsearch.sourceforge.net/mechanize/ https://pypi.org/project/mechanize/"
+SRC_URI="http://wwwsearch.sourceforge.net/${PN}/src/${P}.tar.gz"
+
+LICENSE="|| ( BSD ZPL )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ # Ignore warnings (https://github.com/jjlee/mechanize/issues/issue/13).
+ # https://github.com/jjlee/mechanize/issues/66
+ "${PYTHON}" -W ignore test.py
+}
+
+python_install_all() {
+ # Fix some paths.
+ sed -e "s:../styles/:styles/:g" -i docs/html/* || die "sed failed"
+ if use doc; then
+ dohtml -r docs/html/ docs/styles
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/mechanize/metadata.xml b/dev-python/mechanize/metadata.xml
new file mode 100644
index 000000000000..cc33db8a685e
--- /dev/null
+++ b/dev-python/mechanize/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ mechanize is a Python module for static programmatic web browsing in
+ Python, after Andy Lester's Perl module WWW::Mechanize. With the Browser
+ subclass any url can be opened - not just http - and UserAgentBase
+ offers easy dynamic configuration of user-agent features like protocol,
+ cookie, redirection and robots.txt handling. Other functionalities
+ include easy HTML form filling using ClientForm interface, convenient
+ link parsing and following, browser history with .back() and .reload()
+ methods and automatic handling of HTTP-Equiv and Refresh.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">wwwsearch</remote-id>
+ </upstream>
+</pkgmetadata>