summaryrefslogtreecommitdiff
path: root/dev-python/mpi4py/mpi4py-3.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/mpi4py/mpi4py-3.0.3.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/mpi4py/mpi4py-3.0.3.ebuild')
-rw-r--r--dev-python/mpi4py/mpi4py-3.0.3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/mpi4py/mpi4py-3.0.3.ebuild b/dev-python/mpi4py/mpi4py-3.0.3.ebuild
index 15fba5f284a5..2a020662ac41 100644
--- a/dev-python/mpi4py/mpi4py-3.0.3.ebuild
+++ b/dev-python/mpi4py/mpi4py-3.0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Message Passing Interface for Python"
@@ -36,6 +36,13 @@ PATCHES=(
"${FILESDIR}/${P}-py38futures.patch"
)
+src_prepare() {
+ sed -e 's/++Py_REFCNT/Py_INCREF/' \
+ -e 's/--Py_REFCNT/Py_DECREF/' \
+ -i src/*.c || die
+ distutils-r1_src_prepare
+}
+
python_prepare_all() {
# not needed on install
rm -vr docs/source || die