summaryrefslogtreecommitdiff
path: root/dev-python/mpi4py/mpi4py-3.0.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/mpi4py/mpi4py-3.0.3.ebuild')
-rw-r--r--dev-python/mpi4py/mpi4py-3.0.3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/mpi4py/mpi4py-3.0.3.ebuild b/dev-python/mpi4py/mpi4py-3.0.3.ebuild
index 15fba5f284a5..2a020662ac41 100644
--- a/dev-python/mpi4py/mpi4py-3.0.3.ebuild
+++ b/dev-python/mpi4py/mpi4py-3.0.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Message Passing Interface for Python"
@@ -36,6 +36,13 @@ PATCHES=(
"${FILESDIR}/${P}-py38futures.patch"
)
+src_prepare() {
+ sed -e 's/++Py_REFCNT/Py_INCREF/' \
+ -e 's/--Py_REFCNT/Py_DECREF/' \
+ -i src/*.c || die
+ distutils-r1_src_prepare
+}
+
python_prepare_all() {
# not needed on install
rm -vr docs/source || die