summaryrefslogtreecommitdiff
path: root/dev-python/path/path-16.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-07 10:16:30 +0100
commit2c9fab2a3468abc6862cb3115c9ff63aa266bf57 (patch)
treeb9249df06dd8229d7f334cb2e536d5c56ac81d3c /dev-python/path/path-16.7.1.ebuild
parent0735b7c70f35339a20b45aee2a0a0ad80d118550 (diff)
gentoo auto-resync : 07:07:2023 - 10:16:30
Diffstat (limited to 'dev-python/path/path-16.7.1.ebuild')
-rw-r--r--dev-python/path/path-16.7.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/path/path-16.7.1.ebuild b/dev-python/path/path-16.7.1.ebuild
new file mode 100644
index 000000000000..6cd8ba8201ed
--- /dev/null
+++ b/dev-python/path/path-16.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="
+ https://github.com/jaraco/path/
+ https://pypi.org/project/path/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+)