summaryrefslogtreecommitdiff
path: root/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild')
-rw-r--r--dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild b/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
new file mode 100644
index 000000000000..66c0a794e6ba
--- /dev/null
+++ b/dev-python/picklemagic/picklemagic-0.0_pre20160415.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} )
+inherit python-r1
+
+SRC_URI="https://dev.gentoo.org/~bircoph/distfiles/${P}.tar.xz"
+KEYWORDS="~amd64 ~x86"
+DESCRIPTION="A library for analysing python pickles safely"
+HOMEPAGE="https://github.com/CensoredUsername/picklemagic"
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="doc"
+
+BDEPEND="doc? ( dev-python/sphinx )"
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_compile() {
+ use doc && emake -C doc html
+}
+
+src_install() {
+ default
+ python_foreach_impl python_domodule *.py
+ use doc && dodoc -r doc/build/html
+}