summaryrefslogtreecommitdiff
path: root/dev-python/pyarrow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-28 13:38:19 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-28 13:38:19 +0000
commit1d6bc233e81d1ece6bcd5d781ed786208395d19d (patch)
tree7160f86eceb686bbb5da77a48b2134e0fa11053d /dev-python/pyarrow
parentd46d1d3a5897cade51811b3848c7bf27969da625 (diff)
gentoo auto-resync : 28:12:2023 - 13:38:18
Diffstat (limited to 'dev-python/pyarrow')
-rw-r--r--dev-python/pyarrow/Manifest2
-rw-r--r--dev-python/pyarrow/pyarrow-14.0.2.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pyarrow/Manifest b/dev-python/pyarrow/Manifest
index 5b5e4b7adc6e..1fc637ff9725 100644
--- a/dev-python/pyarrow/Manifest
+++ b/dev-python/pyarrow/Manifest
@@ -1,3 +1,5 @@
DIST apache-arrow-14.0.1.tar.gz 20968461 BLAKE2B 01a4269f98ba2a4de1d6bc29f43a4e97132f8b7bdb3c3d022e0c0ba498527003e8bec0ea0b054f19ae54749f45fe39675f651f6c9e34e815df5a9b9926512431 SHA512 31d19f0ca80349f63db74bae813256b47907f85725a9bf01ef6f32406e79828ebb4701faedb52696b6a5b3bb89ad4e136485fd5eb35d396dd42147c11d4d2713
+DIST apache-arrow-14.0.2.tar.gz 20969982 BLAKE2B 9df119fca564a4140d1143a1ac0614831e4f80846d43439d011b8ca7f5e77461005c96b9430b6dd7ce0ba7496b879a8abc9ffa372e6b455c317abeebb16ae8e4 SHA512 dd6cf6cbb817a48ef5275bb409367e5904526a3c16a17a37ea75101085ea19a71ba6bf936a6f099012e7c528811db1728ef2f14dcb16a1056a22088839280ce0
EBUILD pyarrow-14.0.1.ebuild 1732 BLAKE2B fa80196f4222a802aa56c8d2defb12087e1927df55254adc879689cab866db380b49bd0d463f112d1666934f050ee0235ba8f316d51b43ea1b8d1c08eab6e976 SHA512 868ff4350e4810b59c4ac8f96ea745c738848d1aa47bbd6c4cbfed6b8f0aecd2454e1b8918209a9e080bdf9b49a8dab73faecd7470d624197ecfc55832b5427c
+EBUILD pyarrow-14.0.2.ebuild 1729 BLAKE2B 150cd20ca75cb4d954a2d3f966fd1499e08bee048e3d8d24de45b69838ba0d5bfec462bca509c3998409eece693d28957e12c0565bab23fc1331777aa5d03e4b SHA512 d53f7e263db782aaf78bf3afdecf9ce27ceb81be0cc623b12cf96a3023e332555b5e73066de2377ac23f99b01765196168bca18689515d953d78574c55828813
MISC metadata.xml 454 BLAKE2B aef32100cb88b74361bc57c83179ce223bab58fd2d33c0274011350f1021f8f738008a64b74995d005f9b53edf45d9e0168a38101e041297d38805529b7af416 SHA512 2b7d53db25c36faca27aa8885479396ad2b510d8fba9b421d969fd23505b5026b48a9869ab941fa8d09c2a399ed6f211d8694bc3ed05dc5bf583d7be1fc0e679
diff --git a/dev-python/pyarrow/pyarrow-14.0.2.ebuild b/dev-python/pyarrow/pyarrow-14.0.2.ebuild
new file mode 100644
index 000000000000..c0f420a92293
--- /dev/null
+++ b/dev-python/pyarrow/pyarrow-14.0.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Python library for Apache Arrow"
+HOMEPAGE="
+ https://pypi.org/project/pyarrow/
+ https://arrow.apache.org/
+"
+SRC_URI="mirror://apache/arrow/arrow-${PV}/apache-arrow-${PV}.tar.gz"
+S="${WORKDIR}/apache-arrow-${PV}/python"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="parquet snappy ssl"
+
+RDEPEND="
+ ~dev-libs/apache-arrow-${PV}[compute,dataset,json,parquet?,re2,snappy?,ssl?]
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-lazy-fixture[${PYTHON_USEDEP}]
+ dev-libs/apache-arrow[lz4,zlib]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # wtf?
+ tests/test_fs.py::test_localfs_errors
+ # these require apache-arrow with jemalloc that doesn't seem
+ # to be supported by the Gentoo package
+ tests/test_memory.py::test_env_var
+ tests/test_memory.py::test_specific_memory_pools
+ tests/test_memory.py::test_supported_memory_backends
+)
+
+src_compile() {
+ export PYARROW_PARALLEL="$(makeopts_jobs)"
+ export PYARROW_BUILD_VERBOSE=1
+ export PYARROW_CXXFLAGS="${CXXFLAGS}"
+ export PYARROW_BUNDLE_ARROW_CPP_HEADERS=0
+ export PYARROW_CMAKE_GENERATOR=Ninja
+ export PYARROW_WITH_HDFS=1
+ if use parquet; then
+ export PYARROW_WITH_DATASET=1
+ export PYARROW_WITH_PARQUET=1
+ use ssl && export PYARROW_WITH_PARQUET_ENCRYPTION=1
+ fi
+ if use snappy; then
+ export PYARROW_WITH_SNAPPY=1
+ fi
+
+ distutils-r1_src_compile
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs pyarrow
+}