summaryrefslogtreecommitdiff
path: root/dev-python/pytidylib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pytidylib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pytidylib')
-rw-r--r--dev-python/pytidylib/Manifest3
-rw-r--r--dev-python/pytidylib/metadata.xml12
-rw-r--r--dev-python/pytidylib/pytidylib-0.2.4.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytidylib/Manifest b/dev-python/pytidylib/Manifest
new file mode 100644
index 000000000000..8d486b3736ac
--- /dev/null
+++ b/dev-python/pytidylib/Manifest
@@ -0,0 +1,3 @@
+DIST pytidylib-0.2.4.tar.gz 86650 BLAKE2B 15212651c83ebbec5b74418f37bfcd0366e9b6cdfc0820953e34ec3142871248df02618a51415a36b84ac8c2e5a12d996ff7301b5bf3a001fb42297df3a98202 SHA512 443e9af0fd458d4f041e3b72415839838a4edc83f8a978e5cc0bdf53202584e269f1ad5df10967d8ae4b98b24dcffcf9f5a54e0e3f6cd620a8a6a20171da0811
+EBUILD pytidylib-0.2.4.ebuild 640 BLAKE2B 2592f38ce16cbcc65bf2a16741a4006a4d12b98e4140b7558539cbc4119e728ee27a5cf7df7045c1590e5097acc0998cbcfb4ca7f851ee5055888052362861f1 SHA512 c987bd0531902490041b112f875ea56241af8b9353238512f25319e816cf4837bd0903aeb9f77b21ed9841be2562b094fadf181468559c2f97e80d03cf228674
+MISC metadata.xml 385 BLAKE2B 6c53cf6462d81e85c2a9facf85c0fd7b6c0c870656fdc4cc63bcd67e646d51e14fc9246a7b75a527eccecaf4385677ea63b56dfa04aeab708b41b83c8bc4fcef SHA512 e41d4897a343c45e469fe4cd52a7ce93d525ea208dd570fe0517feda8f445fa9175d971e4c37b8f1941a7cb6931ff6473526ced82384489f02a11c4040fec933
diff --git a/dev-python/pytidylib/metadata.xml b/dev-python/pytidylib/metadata.xml
new file mode 100644
index 000000000000..9badc222f9f2
--- /dev/null
+++ b/dev-python/pytidylib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">countergram/pytidylib</remote-id>
+ <remote-id type="pypi">pytidylib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytidylib/pytidylib-0.2.4.ebuild b/dev-python/pytidylib/pytidylib-0.2.4.ebuild
new file mode 100644
index 000000000000..af2a120838e2
--- /dev/null
+++ b/dev-python/pytidylib/pytidylib-0.2.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for HTML Tidy (tidylib)"
+HOMEPAGE="http://countergram.com/open-source/pytidylib https://github.com/countergram/pytidylib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd"
+IUSE="test"
+
+RDEPEND="app-text/htmltidy"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest )"
+
+python_test() {
+ py.test -vv || die
+}