summaryrefslogtreecommitdiff
path: root/dev-python/sniffio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/sniffio
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/sniffio')
-rw-r--r--dev-python/sniffio/Manifest3
-rw-r--r--dev-python/sniffio/metadata.xml12
-rw-r--r--dev-python/sniffio/sniffio-1.2.0.ebuild31
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/sniffio/Manifest b/dev-python/sniffio/Manifest
new file mode 100644
index 000000000000..3f923af22478
--- /dev/null
+++ b/dev-python/sniffio/Manifest
@@ -0,0 +1,3 @@
+DIST sniffio-1.2.0.gh.tar.gz 17335 BLAKE2B 0d67baa18702ac38932680bdc741c87ee0a31342cc752c1463a7f90720ea0ebf6d62ef682a042c58e8fe96456e1461638e0f02c6f60da5f5e0d07464be27a4a3 SHA512 8e1dd2bb6fc22ee5824adfffe688ff0621b8c1ef5daea594dedce13d5e04a498e05816bb32e9bbed206a653a330ff710df57c888ddcff00a6254eafddc538273
+EBUILD sniffio-1.2.0.ebuild 704 BLAKE2B 4bc4ebfc4854d1948c7bc28cc81142ea9ff92f7b5c8282f2e9d29a6aff2f670b0d6c60f25a954863582ccee6f7fea7ef4b49b0f524fa652972a3bc6b1a9f1e21 SHA512 4fe8462226f3341c25ba582eeadbd0e2a727e9a1a76a68170be79c0e55e3982af4069098a200c1ebba7407fb03525abf1633256d95f3775f6adaaf63dafd977d
+MISC metadata.xml 371 BLAKE2B 478f1662d24966802e436e694aac25833e80895c91034e36220294809df800bfb3686d087e8aa4cc3861df33ecbbbb1253fed8791a0b6a17c53f059093390dae SHA512 d5d36379d6a7c2e90a5ba5b96f2c0168267581ce9d29d15cc60821300b751ece3f5a1d3c2a1327733a6b61faa416f3fa4777977169a370b059e11ef6d3d6e87c
diff --git a/dev-python/sniffio/metadata.xml b/dev-python/sniffio/metadata.xml
new file mode 100644
index 000000000000..0c53f9f9d1e2
--- /dev/null
+++ b/dev-python/sniffio/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">python-trio/sniffio</remote-id>
+ <remote-id type="pypi">sniffio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sniffio/sniffio-1.2.0.ebuild b/dev-python/sniffio/sniffio-1.2.0.ebuild
new file mode 100644
index 000000000000..89f3dc32585e
--- /dev/null
+++ b/dev-python/sniffio/sniffio-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Sniff out which async library your code is running under"
+HOMEPAGE="
+ https://github.com/python-trio/sniffio/
+ https://pypi.org/project/sniffio/"
+SRC_URI="
+ https://github.com/python-trio/sniffio/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # curio is not packaged
+ sniffio/_tests/test_sniffio.py::test_curio
+ )
+
+ pytest -vv ${deselect[@]/#/--deselect } ||
+ die "Tests failed with ${EPYTHON}"
+}