summaryrefslogtreecommitdiff
path: root/dev-python/threadpoolctl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-14 10:36:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-14 10:36:56 +0100
commit5af5a2b4acc97daacc0bf0e1d4e85ec780734689 (patch)
treec3e48a276c7fda27c8e30b6b8864e178e5c496fb /dev-python/threadpoolctl
parent605eb6cd753ab91e58e7561ebad2e75a44bcccc4 (diff)
gentoo auto-resync : 14:07:2023 - 10:36:56
Diffstat (limited to 'dev-python/threadpoolctl')
-rw-r--r--dev-python/threadpoolctl/Manifest4
-rw-r--r--dev-python/threadpoolctl/metadata.xml1
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild36
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
index 3ff714841bcd..8b5bfac01da1 100644
--- a/dev-python/threadpoolctl/Manifest
+++ b/dev-python/threadpoolctl/Manifest
@@ -1,3 +1,5 @@
DIST threadpoolctl-3.1.0.tar.gz 29899 BLAKE2B 41bddace1231107a108fd57e281541a4e9f04c9bee957d16cfbff49361f9dcb0b879bf376617480b1ca2929c09d07fd1f8f704afa4ad85e34e38c4a82fb48a3c SHA512 551dad4c93a62382583a96187f795aaeb6954700647c984ad618d3d1bede50d6859e75f676c557fa875db37c798c0347131f6b136148f71b8208783c7f8f717e
+DIST threadpoolctl-3.2.0.gh.tar.gz 32196 BLAKE2B 662b2ab6908719c11881dbaba00437b049f71dc8b6c5c8f4c3733cd156312a6410eca19d0446e11cfaddd039261adb25398a3827e822584ad52b428e67fc6b17 SHA512 01017047ceaa353239fea5410be3b6cd924068d7e18a80bc04cc07f08341e3405fa8620a8e5f43f16b674a3ce535d15e42b41741f78079fb61e618c8b9d1583d
EBUILD threadpoolctl-3.1.0.ebuild 571 BLAKE2B a184046c1b66ec05f0827cb597a9a2e920f67adf38fa9a112c9a2d34dc67a2feb45e0a5caa90c39befed78a62cee8548a56b9fcf028e1c176d2978d454d0fe57 SHA512 efc232b1350d885df1b2666bf3e67d62aae0f4ca63f108d3642ee70c4659f146a0dc7aad874ff40b5723ca10998cc5780e531314936f856d7cf3706632bb5ae3
-MISC metadata.xml 429 BLAKE2B 85d3a98dd9d79c2e11cc44fd2e474d1278ce744a8c36887e9d458125eef41a231cce19ddd8b9fbfdb605ed9e5c5c7bbf35f2844cdbb7d7e557693ded1c1663bc SHA512 f7d15360b5cec34491ea88db7919aeaa0c353bbeed2958a25c34aa93b23a9fdd97c8c910f2623454eb78d74766e0aecde58852b9528dfd0f635ea5c6aeb28f8b
+EBUILD threadpoolctl-3.2.0.ebuild 860 BLAKE2B 241252df4db5fb67ac2c59c9d16829a76e083a57577f07fdc2ba5d76aaca6cb0215cb022899e94100ca09f2b4f832f22da45e48b9014d8b2a078a6e75b2ff0de SHA512 f2e69748192cf9d1aa1208dac9d41d95988ee07e79674b364c20f22efd7d7cfcceffbde4761fb4c6f5fcd0a01f191d6533ca2a1c21b142a1c1991c5fac5e4206
+MISC metadata.xml 489 BLAKE2B eba7a68832688f4c6cca1f30e188bae378c82347d87d7a0186fe3821dd04b75fdda2a7826785c3a59eda7362d1119d183be239b06c90ce14096e5a87459d2a29 SHA512 e14a5317dcfb8506a277d358ec227d276cf148e0293fc56b14751804a89fa20134b5be752fcc8beaffd12e246722d34120449a8f1ea0900e2918e42889c54dd8
diff --git a/dev-python/threadpoolctl/metadata.xml b/dev-python/threadpoolctl/metadata.xml
index eba9ec605bae..e556ca8c76c9 100644
--- a/dev-python/threadpoolctl/metadata.xml
+++ b/dev-python/threadpoolctl/metadata.xml
@@ -10,6 +10,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">joblib/threadpoolctl</remote-id>
<remote-id type="pypi">threadpoolctl</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
new file mode 100644
index 000000000000..c80290ae5121
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-3.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="
+ https://github.com/joblib/threadpoolctl/
+ https://pypi.org/project/threadpoolctl/
+"
+SRC_URI="
+ https://github.com/joblib/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Asserts against a hardcoded list of CPUs. Either we skip it
+ # or file bugs about missing architectures until upstream realizes
+ # how bad idea that were.
+ tests/test_threadpoolctl.py::test_architecture
+)