summaryrefslogtreecommitdiff
path: root/dev-ruby/connection_pool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-ruby/connection_pool
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-ruby/connection_pool')
-rw-r--r--dev-ruby/connection_pool/Manifest2
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.3.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/Manifest b/dev-ruby/connection_pool/Manifest
index 248ab8f30055..578a61f31347 100644
--- a/dev-ruby/connection_pool/Manifest
+++ b/dev-ruby/connection_pool/Manifest
@@ -1,3 +1,5 @@
DIST connection_pool-2.2.2.gem 13824 BLAKE2B 2f52bb3451dec5916d5797596f7bc3dbf39845321ee83736d679c433e96f154db852469b1f6d0d3b7c7f48262f7840087d89cdd40ece22b67a29c20ff77274dd SHA512 74cb64aa3f183ee4e41f438133f60581e9f99a1d5b5daf61607cff2329bfb1fbd8810d87c35d709418a22ad925049e3e9403a602107452414a67aee1c6eecfe9
+DIST connection_pool-2.2.3.gem 13824 BLAKE2B b74666181790e678793023413eedbd5b68836e6d480d79f6c12d512277a1917db0d400e08be98c098305ca065a12988bcac9d46f89b4c1380d758991490a540b SHA512 a5e54b11073723d5cf5150a47c38b37ef8e58e9adb056eeedc4427207ed1ae5d1844cab925bbbcc8a2a9dd3fe9373593ab735ce4de588b89db97800fb74757ac
EBUILD connection_pool-2.2.2.ebuild 731 BLAKE2B 37ca896432e4aba932c2ee253636932b0dbf14d7bba7ba1646cb8778469e15254628b31e361d4f4fccd23c564e67fe22fdd5d4fbb1bd15b7de4be907eb8133dd SHA512 a9ad336e9ec89a980b630e499a58a0cf2ca318369c5b52b698202521cbcb09ac0cab2fd06e23ea78169d735a9c07a25e4cf062b268768f4d0acddecac59a61b7
+EBUILD connection_pool-2.2.3.ebuild 753 BLAKE2B 97d6521caf8a157ef90ab6c5b2253d734e9ca681c4ab6b0e45d20f9e41143ab8a3f5ebdf1da304e6261167f8b2cc24eff8cffe8b69d564d504cad546c769e026 SHA512 11606e8a00ede33872b5c8e8c22481e3e8dc93ff511e0ec749ec27ce1864818db7c0d99533a8527e672c95e167832d182bdcfbdc50934670142732f64d416d00
MISC metadata.xml 349 BLAKE2B 7ffc13174f2f47522a66c48922952798d03fbbb15419d9a52e183c633b56d863e85fab4682420aa9fffeb16d474f52de30799489a99221f25438524dbc569303 SHA512 18245f101f862c5880a42121eac9947a22fac206823d85ba650f5766af334208a64f97e7ea44e298f4f3c1191eb6bbf0e37949974c737060dd66434e1963b41c
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.3.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.3.ebuild
new file mode 100644
index 000000000000..194ac6f8667a
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}