summaryrefslogtreecommitdiff
path: root/games-arcade/excido/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /games-arcade/excido/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'games-arcade/excido/files')
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-build.patch29
-rw-r--r--games-arcade/excido/files/excido-0.1.5c-freealut.patch38
2 files changed, 67 insertions, 0 deletions
diff --git a/games-arcade/excido/files/excido-0.1.5c-build.patch b/games-arcade/excido/files/excido-0.1.5c-build.patch
new file mode 100644
index 000000000000..1735b51ccdfc
--- /dev/null
+++ b/games-arcade/excido/files/excido-0.1.5c-build.patch
@@ -0,0 +1,29 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,8 @@
+-CC=g++
+-CFLAGS=`sdl-config --cflags` #-g -Wall #-O2
++CXX?=g++
++CXXFLAGS+=$(shell sdl-config --cflags) #-g -Wall #-O2
+ #CFLAGS=`sdl-config --cflags` -I./physfs#-g -Wall #-O2
+ OBJS := ${patsubst %.cpp, %.o, ${wildcard src/*.cpp}}
+-LIBS = -s -Bstatic `sdl-config --static-libs` -lSDL_image -lSDL_ttf -L. -lphysfs -lopenal -Bdynamic -lGL -lGLU
++LIBS = $(shell sdl-config --libs) -lSDL_image -lSDL_ttf -lphysfs -lopenal -lalut -lGL -lGLU
+ #LIBS = -s -Bstatic `sdl-config --static-libs` SDL_image/*.o SDL_ttf/*.o -L. physfs/*.o openal/*.o -ljpeg -lpng -ltiff -lfreetype -Bdynamic -lGL -lGLU
+ PREFIX=/usr/local
+ BINDIR=$(PREFIX)/bin/
+@@ -16,12 +16,12 @@
+
+
+ .cpp.o:
+- $(CC) $(CFLAGS) $(DEFINES) -o ${patsubst %.cpp, %.o, $<} -c $<
++ $(CXX) $(CXXFLAGS) $(DEFINES) -o ${patsubst %.cpp, %.o, $<} -c $<
+
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CC) $(CFLAGS) -o $(TARGET) $(LIBS) $(OBJS)
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $(TARGET) $(OBJS) $(LIBS)
+
+ clean:
+ rm -f $(OBJS) $(TARGET)
diff --git a/games-arcade/excido/files/excido-0.1.5c-freealut.patch b/games-arcade/excido/files/excido-0.1.5c-freealut.patch
new file mode 100644
index 000000000000..c29999fae25d
--- /dev/null
+++ b/games-arcade/excido/files/excido-0.1.5c-freealut.patch
@@ -0,0 +1,38 @@
+--- a/src/SoundCore.cpp
++++ b/src/SoundCore.cpp
+@@ -352,32 +352,13 @@
+
+ PHYSFS_close(filehandle);
+
+- ALenum format;
+- ALvoid *data;
+- ALsizei size,freq;
+- ALboolean loop=AL_FALSE;
+ ALenum error;
+
+ alGetError();
+
+- alGenBuffers(1,&newsample.alid);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alGenBuffers\n");
+- PrintALError(error);
+- }
+- alutLoadWAVMemory((ALbyte*)filedata,&format,&data,&size,&freq,&loop);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alutLoadWAVMemory\n");
+- PrintALError(error);
+- }
+- alBufferData(newsample.alid,format,data,size,freq);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alBufferData\n");
+- PrintALError(error);
+- }
+- alutUnloadWAV(format,data,size,freq);
+- if((error=alGetError())!=AL_NO_ERROR){
+- fprintf(stderr,"SoundCore::LoadSample: Error on alutUnloadWAV\n");
++ newsample.alid=alutCreateBufferFromFileImage(filedata, filesize);
++ if(((error=alGetError())!=AL_NO_ERROR)||(newsample.alid==AL_NONE)){
++ fprintf(stderr,"SoundCore::LoadSample: Error on alutCreateBufferFromFileImage\n");
+ PrintALError(error);
+ }
+