summaryrefslogtreecommitdiff
path: root/games-rpg/asphyxia/asphyxia-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /games-rpg/asphyxia/asphyxia-1.0.ebuild
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'games-rpg/asphyxia/asphyxia-1.0.ebuild')
-rw-r--r--games-rpg/asphyxia/asphyxia-1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-rpg/asphyxia/asphyxia-1.0.ebuild b/games-rpg/asphyxia/asphyxia-1.0.ebuild
new file mode 100644
index 000000000000..979aa1a146d9
--- /dev/null
+++ b/games-rpg/asphyxia/asphyxia-1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="Asphyxia"
+
+DESCRIPTION="Visual novel where the main character has one day to make peace with her friend"
+HOMEPAGE="https://ebihime.itch.io/${PN}"
+SRC_URI="${MY_PN}-${PV}-linux.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN}-${PV}-linux"
+
+pkg_nofetch() {
+ einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+ einfo "it to your distfiles directory. If you have some other version then"
+ einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins -r game/*
+
+ make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+ newicon -s 48 icon.png ${PN}.png
+ make_desktop_entry ${PN} "${MY_PN}"
+
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }