summaryrefslogtreecommitdiff
path: root/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-17 06:49:08 +0000
commit2bf68d7062b64d9f815f3b8ce6942a66afe53b0d (patch)
treeac1e773aaa4d3575d18d178ae260cab963bbf64c /media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
parentcd356b722fd8d162f02a5059fae1a66e00be52e3 (diff)
gentoo auto-resync : 17:03:2024 - 06:49:08
Diffstat (limited to 'media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild')
-rw-r--r--media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild b/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..174d912e442b
--- /dev/null
+++ b/media-libs/libfishsound/libfishsound-1.0.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple programming interface to decode and encode audio with vorbis or speex"
+HOMEPAGE="https://www.xiph.org/fishsound/"
+SRC_URI="https://downloads.xiph.org/releases/libfishsound/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac speex"
+
+RDEPEND="
+ media-libs/libogg
+ media-libs/libvorbis
+ flac? ( media-libs/flac:= )
+ speex? ( media-libs/speex )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# bug #395153
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pc.patch
+ "${FILESDIR}"/${PN}-1.0.0-c99.patch
+)
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:doxygen:doxygen-dummy:' \
+ configure || die
+}
+
+src_configure() {
+ local myconf="--disable-static"
+ use flac || myconf="${myconf} --disable-flac"
+ use speex || myconf="${myconf} --disable-speex"
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir="${D}/usr/share/doc/${PF}" install
+ dodoc AUTHORS ChangeLog README
+ find "${ED}" -name '*.la' -delete || die
+}