summaryrefslogtreecommitdiff
path: root/media-video/gpac/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /media-video/gpac/files
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'media-video/gpac/files')
-rw-r--r--media-video/gpac/files/gpac-1.0.0-makefile-debian.patch13
-rw-r--r--media-video/gpac/files/gpac-1.0.0-zlib-compile.patch33
-rw-r--r--media-video/gpac/files/gpac-1.0.1-configure.patch117
3 files changed, 163 insertions, 0 deletions
diff --git a/media-video/gpac/files/gpac-1.0.0-makefile-debian.patch b/media-video/gpac/files/gpac-1.0.0-makefile-debian.patch
new file mode 100644
index 000000000000..8bb8074b1ce8
--- /dev/null
+++ b/media-video/gpac/files/gpac-1.0.0-makefile-debian.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index b147725..244b07c 100644
+--- a/Makefile
++++ b/Makefile
+@@ -164,7 +164,7 @@ ifneq ($(CONFIG_DARWIN),yes)
+ $(INSTALL) -d "$(DESTDIR)$(prefix)/share/pixmaps"
+ $(INSTALL) -d "$(DESTDIR)$(prefix)/share/applications"
+
+-ifeq ($(IS_DEB_MAKE),undefined)
++ifeq ($(IS_DEB_MAKE),)
+ ln -sf $(DESTDIR)$(prefix)/share/gpac/res/gpac.png $(DESTDIR)/usr/share/pixmaps/gpac.png
+ $(INSTALL) $(INSTFLAGS) -m 644 $(SRC_PATH)/share/gpac.desktop "$(DESTDIR)/usr/share/applications/"
+ else
diff --git a/media-video/gpac/files/gpac-1.0.0-zlib-compile.patch b/media-video/gpac/files/gpac-1.0.0-zlib-compile.patch
new file mode 100644
index 000000000000..c5b1fc4ab56f
--- /dev/null
+++ b/media-video/gpac/files/gpac-1.0.0-zlib-compile.patch
@@ -0,0 +1,33 @@
+Index: gpac-1.0.0/src/utils/gzio.c
+===================================================================
+--- gpac-1.0.0.orig/src/utils/gzio.c
++++ gpac-1.0.0/src/utils/gzio.c
+@@ -93,10 +93,10 @@ typedef struct gz_stream {
+ //local gzFile gz_open OF((const char *path, const char *mode, int fd));
+ //local int do_flush OF((gzFile file, int flush));
+ //local int get_byte OF((gz_stream *s));
+-local void check_header OF((gz_stream *s));
+-local int destroy OF((gz_stream *s));
++local void check_header _Z_OF((gz_stream *s));
++local int destroy _Z_OF((gz_stream *s));
+ //local void putLong OF((FILE *file, uLong x));
+-local uLong getLong OF((gz_stream *s));
++local uLong getLong _Z_OF((gz_stream *s));
+
+ /* ===========================================================================
+ Opens a gzip (.gz) file for reading or writing. The mode parameter
+Index: gpac-1.0.0/src/utils/zutil.h
+===================================================================
+--- gpac-1.0.0.orig/src/utils/zutil.h
++++ gpac-1.0.0/src/utils/zutil.h
+@@ -262,8 +262,8 @@ extern void z_error OF((char *m));
+ #endif
+
+
+-voidpf zcalloc OF((voidpf opaque, unsigned items, unsigned size));
+-void zcfree OF((voidpf opaque, voidpf ptr));
++voidpf zcalloc _Z_OF((voidpf opaque, unsigned items, unsigned size));
++void zcfree _Z_OF((voidpf opaque, voidpf ptr));
+
+ #define ZALLOC(strm, items, size) \
+ (*((strm)->zalloc))((strm)->opaque, (items), (size))
diff --git a/media-video/gpac/files/gpac-1.0.1-configure.patch b/media-video/gpac/files/gpac-1.0.1-configure.patch
new file mode 100644
index 000000000000..e471157af6b6
--- /dev/null
+++ b/media-video/gpac/files/gpac-1.0.1-configure.patch
@@ -0,0 +1,117 @@
+* Makes static libs optional
+* Removes auto-SSE2 detection
+----
+diff --git a/Makefile b/Makefile
+index 303a413..1ef750e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -284,8 +284,9 @@ ifeq ($(GPAC_ENST),yes)
+ endif
+
+ $(INSTALL) -d "$(DESTDIR)$(prefix)/$(lib_dir)"
++ifeq ($(STATIC_LIBS), yes)
+ $(INSTALL) $(INSTFLAGS) -m 644 "./bin/gcc/libgpac_static.a" "$(DESTDIR)$(prefix)/$(lib_dir)" || true
+-
++endif
+ $(INSTALL) -d $(DESTDIR)$(prefix)/$(lib_dir)/pkgconfig
+ $(INSTALL) $(INSTFLAGS) -m 644 gpac.pc "$(DESTDIR)$(prefix)/$(lib_dir)/pkgconfig"
+
+diff --git a/configure b/configure
+index de8ea99..4f5a6a8 100755
+--- a/configure
++++ b/configure
+@@ -105,6 +105,7 @@ has_dvb4linux="no"
+ has_openjpeg="no"
+ gprof_build="no"
+ static_build="no"
++static_libs="no"
+ want_pic="no"
+ want_gcov="no"
+ has_joystick="no"
+@@ -264,6 +265,7 @@ GPAC configuration options:
+ --enable-amr-wb enable AMR WB library
+ --enable-amr enable both AMR NB and WB libraries
+ --enable-static-bin link statically against libgpac
++ --enable-static-lib GPAC static libraries build
+ --static-mp4box configure for static linking of MP4Box only.
+ --enable-depth enables depth handling in the compositor
+
+@@ -706,14 +708,6 @@ if docc -lz -Wno-pointer-sign ; then
+ fi
+
+
+-#GCC opt
+-if test "$no_gcc_opt" = "no"; then
+- CFLAGS="-O3 $CFLAGS"
+-else
+- CFLAGS="-O0 $CFLAGS"
+-fi
+-
+-
+ #GCC PIC
+ if test "$cross_prefix" != "" ; then
+ want_pic="no"
+@@ -1710,6 +1704,8 @@ for opt do
+ ;;
+ --enable-static-bin) static_build="yes";
+ ;;
++ --enable-static-libs) static_libs="yes";
++ ;;
+ --disable-ipv6) has_ipv6="no"
+ ;;
+ --disable-platinum) has_platinum="no"
+@@ -2357,6 +2353,7 @@ echo "** GPAC $version rev$revision Core Configuration **"
+ echo "debug version: $debuginfo"
+ echo "GProf enabled: $gprof_build"
+ echo "Static build enabled: $static_build"
++echo "Static libs enabled: $static_libs"
+ echo "Memory tracking enabled: $use_memory_tracking"
+ echo "Sanitizer enabled: $enable_sanitizer"
+ echo "Fixed-Point Version: $use_fixed_point"
+@@ -3049,6 +3046,7 @@ echo "DEBUGBUILD=$debuginfo" >> config.mak
+ echo "GPROFBUILD=$gprof_build" >> config.mak
+ echo "MP4BOX_STATIC=$static_mp4box" >> config.mak
+ echo "STATICBUILD=$static_build" >> config.mak
++echo "STATICLIBS=$static_libs" >> config.mak
+
+ echo "CONFIG_IPV6=$has_ipv6" >> config.mak
+ if test "$has_ipv6" = "yes" ; then
+diff --git a/src/Makefile b/src/Makefile
+index c483c8d..b24d5bb 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -347,7 +347,6 @@ filters_svc: $(LIBGPAC_FILTERS_SVC)
+ @echo "LIBS $(EXTRALIBS)"
+
+ ifeq ($(CONFIG_DARWIN),yes)
+-
+ $(LIBTOOL) -s -o ../bin/gcc/libgpac_static.a $(OBJS)
+ $(RANLIB) ../bin/gcc/libgpac_static.a
+ ifneq ($(STATICBUILD),yes)
+@@ -355,9 +354,10 @@ ifneq ($(STATICBUILD),yes)
+ endif
+
+ else
+-
++ifeq ($(STATICLIBS), yes)
+ $(AR) cr ../bin/gcc/libgpac_static.a $(OBJS)
+ $(RANLIB) ../bin/gcc/libgpac_static.a
++endif
+ ifneq ($(STATICBUILD),yes)
+ $(CC) $(SHFLAGS) $(LD_SONAME) -o $@ $(OBJS) $(EXTRALIBS) $(LDFLAGS)
+ mv $@ $@.$(VERSION_SONAME)
+diff --git a/configure b/configure
+index 4f5a6a8..baba248 100755
+--- a/configure
++++ b/configure
+@@ -735,10 +735,6 @@ cat > $TMPC << EOF
+ int main( void ) { return 0; }
+ EOF
+
+-if docc -msse2 $LDFLAGS ; then
+- CFLAGS="$CFLAGS -msse2"
+-fi
+-
+
+ #look for zlib
+ cat > $TMPC << EOF