summaryrefslogtreecommitdiff
path: root/net-misc/seafile/seafile-8.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /net-misc/seafile/seafile-8.0.5.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'net-misc/seafile/seafile-8.0.5.ebuild')
-rw-r--r--net-misc/seafile/seafile-8.0.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-misc/seafile/seafile-8.0.5.ebuild b/net-misc/seafile/seafile-8.0.5.ebuild
new file mode 100644
index 000000000000..ef6a84798688
--- /dev/null
+++ b/net-misc/seafile/seafile-8.0.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+RELEASE_COMMIT="28ede40ebeca4f046c1d6625ac69fd4949e66042"
+
+inherit autotools python-single-r1 vala
+
+DESCRIPTION="File syncing and sharing software with file encryption and group sharing"
+HOMEPAGE="https://www.seafile.com/ https://github.com/haiwen/seafile/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/${RELEASE_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_USEDEP}]
+ ')
+ dev-libs/openssl:=
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/jansson:=
+ dev-libs/libevent:=
+ net-libs/libsearpc[${PYTHON_SINGLE_USEDEP}]
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ $(vala_depend)"
+
+S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+
+src_prepare() {
+ default
+ eautoreconf
+ vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"/usr/bin/seaf-cli
+}