summaryrefslogtreecommitdiff
path: root/net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch')
-rw-r--r--net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch b/net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch
new file mode 100644
index 000000000000..ff9956fee41c
--- /dev/null
+++ b/net-wireless/uhd/files/uhd-3.10.3.0-tinfo.patch
@@ -0,0 +1,34 @@
+--- host/utils/latency/CMakeLists.txt.orig 2017-05-11 19:44:54.824946672 +0300
++++ host/utils/latency/CMakeLists.txt 2017-05-11 19:45:08.498880360 +0300
+@@ -35,7 +35,8 @@
+ GET_FILENAME_COMPONENT(name ${source} NAME_WE)
+ ADD_EXECUTABLE(${name} ${source} ${latency_lib_path})
+ LIBUHD_APPEND_SOURCES(${name})
+- TARGET_LINK_LIBRARIES(${name} uhd ${Boost_LIBRARIES} ${CURSES_LIBRARIES})
++ TARGET_LINK_LIBRARIES(${name} uhd ${Boost_LIBRARIES}
++ ${CURSES_LIBRARIES} tinfo)
+ UHD_INSTALL(TARGETS ${name} RUNTIME DESTINATION ${latency_comp_dest} COMPONENT ${latency_comp_name})
+ ENDFOREACH(source)
+
+--- host/examples/CMakeLists.txt.orig 2017-05-11 19:41:02.322302577 +0300
++++ host/examples/CMakeLists.txt 2017-05-11 19:44:32.604066325 +0300
+@@ -59,7 +59,7 @@
+ IF(CURSES_FOUND)
+ INCLUDE_DIRECTORIES(${CURSES_INCLUDE_DIR})
+ ADD_EXECUTABLE(rx_ascii_art_dft rx_ascii_art_dft.cpp)
+- TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} ${Boost_LIBRARIES})
++ TARGET_LINK_LIBRARIES(rx_ascii_art_dft uhd ${CURSES_LIBRARIES} tinfo ${Boost_LIBRARIES})
+ UHD_INSTALL(TARGETS rx_ascii_art_dft RUNTIME DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)
+ ENDIF(CURSES_FOUND)
+
+--- host/CMakeLists.txt.orig 2017-05-11 19:36:38.944798634 +0300
++++ host/CMakeLists.txt 2017-05-11 19:36:40.819788408 +0300
+@@ -436,6 +436,8 @@
+ LIST(APPEND UHD_LINK_LIST_STATIC "usb-1.0")
+ ENDIF(ENABLE_USB)
+
++LIST(APPEND UHD_LINK_LIST_STATIC "tinfo")
++
+ CONFIGURE_FILE(
+ ${CMAKE_SOURCE_DIR}/cmake/Modules/UHDConfigVersion.cmake.in
+ ${CMAKE_BINARY_DIR}/cmake/Modules/UHDConfigVersion.cmake