summaryrefslogtreecommitdiff
path: root/sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch')
-rw-r--r--sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch
new file mode 100644
index 000000000000..75f673f63d47
--- /dev/null
+++ b/sci-libs/rocBLAS/files/rocBLAS-5.0.2-unbundle-Tensile.patch
@@ -0,0 +1,25 @@
+Index: rocBLAS-rocm-5.0.2/CMakeLists.txt
+===================================================================
+--- rocBLAS-rocm-5.0.2.orig/CMakeLists.txt
++++ rocBLAS-rocm-5.0.2/CMakeLists.txt
+@@ -271,20 +271,6 @@ if(NOT SKIP_LIBRARY)
+ set( Tensile_ROOT "${CMAKE_BINARY_DIR}/virtualenv/Lib/site-packages/Tensile" )
+ endif()
+
+- include(virtualenv)
+- if (Tensile_TEST_LOCAL_PATH)
+- virtualenv_install(${Tensile_TEST_LOCAL_PATH})
+- message (STATUS "using local Tensile from ${Tensile_TEST_LOCAL_PATH}, copied to ${Tensile_ROOT}")
+- else()
+- # Use the virtual-env setup and download package from specified repot:
+- set( tensile_fork "ROCmSoftwarePlatform" CACHE STRING "Tensile fork to use" )
+- file (STRINGS "tensile_tag.txt" read_tensile_tag)
+- set( tensile_tag ${read_tensile_tag} CACHE STRING "Tensile tag to download" )
+- virtualenv_install("git+https://github.com/${tensile_fork}/Tensile.git@${tensile_tag}")
+- message (STATUS "using GIT Tensile fork=${tensile_fork} from branch=${tensile_tag}")
+- endif()
+- message(STATUS "Adding ${VIRTUALENV_HOME_DIR} to CMAKE_PREFIX_PATH")
+- list(APPEND CMAKE_PREFIX_PATH ${VIRTUALENV_HOME_DIR})
+ if (TENSILE_VERSION)
+ find_package(Tensile ${TENSILE_VERSION} EXACT REQUIRED HIP LLVM OpenMP PATHS "${INSTALLED_TENSILE_PATH}")
+ else()