summaryrefslogtreecommitdiff
path: root/x11-apps/xisxwayland/xisxwayland-2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-24 20:48:34 +0100
commit9d0673651c57438d51e18c6b8ca894d0491b2df3 (patch)
treec5b6cd187b8998d2c56d3b279ac425973d4c3a33 /x11-apps/xisxwayland/xisxwayland-2.ebuild
parentbe21a4c281fc76681a84dd2f103e850866ce4946 (diff)
gentoo auto-resync : 24:08:2022 - 20:48:33
Diffstat (limited to 'x11-apps/xisxwayland/xisxwayland-2.ebuild')
-rw-r--r--x11-apps/xisxwayland/xisxwayland-2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-apps/xisxwayland/xisxwayland-2.ebuild b/x11-apps/xisxwayland/xisxwayland-2.ebuild
new file mode 100644
index 000000000000..aaa53f42f155
--- /dev/null
+++ b/x11-apps/xisxwayland/xisxwayland-2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"