summaryrefslogtreecommitdiff
path: root/x11-libs/goocanvas/goocanvas-3.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-16 20:27:28 +0000
commit2fd57282f0262ca084e05b0f2c63fbada395d02b (patch)
tree4e0f23cea9ce9fd972e70ebc5214bf36fed465cc /x11-libs/goocanvas/goocanvas-3.0.0.ebuild
parentc3bc61051d7f12b4c682efa7a5460bbc8815649e (diff)
gentoo resync : 16.01.2021
Diffstat (limited to 'x11-libs/goocanvas/goocanvas-3.0.0.ebuild')
-rw-r--r--x11-libs/goocanvas/goocanvas-3.0.0.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-libs/goocanvas/goocanvas-3.0.0.ebuild b/x11-libs/goocanvas/goocanvas-3.0.0.ebuild
new file mode 100644
index 000000000000..16b18094e850
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-3.0.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2
+
+DESCRIPTION="Canvas widget for GTK+ using the cairo 2D library for drawing"
+HOMEPAGE="https://wiki.gnome.org/GooCanvas"
+
+LICENSE="LGPL-2"
+SLOT="3.0"
+KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples +introspection"
+
+RDEPEND="
+ >=x11-libs/cairo-1.10.0
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3
+ introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.16
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Do not build demos
+ sed -e 's/^\(SUBDIRS =.*\)demo\(.*\)$/\1\2/' \
+ -i Makefile.{am,in} || die "Failed to sed demo"
+
+ # Python bindings are built/installed manually, but not at all anymore (py2).
+ sed -e "/SUBDIRS = python/d" \
+ -i bindings/Makefile.{am,in} || die "Failed to sed python subdirs"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ PYTHON=true gnome2_src_configure \
+ --disable-rebuilds \
+ --disable-static \
+ $(use_enable introspection) \
+ --disable-python
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ insinto "/usr/share/doc/${P}/examples/"
+ doins demo/*.[ch] demo/*.png
+ fi
+}