summaryrefslogtreecommitdiff
path: root/x11-plugins/wmpop3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /x11-plugins/wmpop3
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'x11-plugins/wmpop3')
-rw-r--r--x11-plugins/wmpop3/Manifest1
-rw-r--r--x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-plugins/wmpop3/Manifest b/x11-plugins/wmpop3/Manifest
index 68f8c09bebf9..ede52671439f 100644
--- a/x11-plugins/wmpop3/Manifest
+++ b/x11-plugins/wmpop3/Manifest
@@ -2,4 +2,5 @@ AUX wmpop3-0.5.6a-fno-common.patch 799 BLAKE2B 25c90a1dc1e1ebc21c439172ffcc67f98
AUX wmpop3-0.5.6a-list.patch 3057 BLAKE2B b9cd76c4e3b6f3643f2aacdb14e49a3d5ba8fdf51f94abeb7473e12923e72be32663870ac8b31475d95bf0dcd06ce8fb1cd007dc1d4fd3300fdf626a90d0eadf SHA512 f0d9a4efeb924dd7a0cae1169404c81529f1e7262684872845db9e3b5b415fe2b48061d778d9829526a1ee8ce66aba48018d9d8ab329f11652d692c322786c3c
DIST WMPop3-0.5.6a.tar.gz 23532 BLAKE2B faef591c9280cb7e37a5071cd2226b84bfb7a49d8b4639085d5b6a44bac8bb3763ca51bd1923d47b8d971010f9b8a7d5d48c6f9a6c76fd3db5cbc00333edc63d SHA512 127dfd3d4dec8a58c991a9bc0d2d1d1c0e9c0ef36af9b2894283bbda129db9b3464c43aa053152f9c0d25eee31b94ffec329784ffa256ce04cb233b809791c2f
EBUILD wmpop3-0.5.6a-r1.ebuild 766 BLAKE2B 9fc55bfad5ec4cfc84b2dae8f551c68c6ea45b016d600203475fa81224539db7aa0997c76f39d758397a019acdb4af537a015530a3e43208caf0cbd1f0b1d1de SHA512 90be62e10fb3fe639b7ea2706421557ff5d49fcb8f5c2a816f8ece3b16ed3ac085d14449722f633bc3d24f699881335c5aaa2652cc5ecd6d396fa2df327fb66d
+EBUILD wmpop3-0.5.6a-r2.ebuild 763 BLAKE2B 3ef73cd0229c3103ac1d59ffbbdf48c3cb164e5fe8b518f19b681f35ced03c5cbb59c9be53f0299c2b8b4f3caf7a843db9a1a9c7144ead9f3a812bc3a4866d9f SHA512 0594774fa7b0e2893cc18cb005d3b3b78ad8e93e38a3288f22f60cc8768f852ccb427ed16640bdeafa8940a00b212eb4c5e95cbe1ddf1b1217b5548938a7196f
MISC metadata.xml 433 BLAKE2B 5ca15a88c67f234f93d1cc5a9c2f8e9f6607cbed53ac530c78849dc022cd21981231954fcb4f0316dfb2fee5fb1e714a980cf616186d6b3847698c6a97300da4 SHA512 9f320eb2d958eb000655fafe326ea0ef5247c655d472332d4d21e18e2368e5dd0cbe63a1d1e63912eb46372e489046bfc6861ebcdde841ff7a26aa0a1a2f3c40
diff --git a/x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild b/x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild
new file mode 100644
index 000000000000..7571699de25f
--- /dev/null
+++ b/x11-plugins/wmpop3/wmpop3-0.5.6a-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Dockapp for checking pop3 accounts"
+HOMEPAGE="https://www.dockapps.net/wmpop3"
+SRC_URI="https://www.dockapps.net/download/${P/wmpop3/WMPop3}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DEPEND="x11-wm/windowmaker
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-list.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ )
+
+src_prepare() {
+ sed -e "s|cc |$(tc-getCC) |" \
+ -e "s|-O2|${CFLAGS}|" \
+ -e "s|-o wmpop3|${LDFLAGS} -o wmpop3|" \
+ -i ${PN}/Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake -C wmpop3
+}
+
+src_install() {
+ dobin wmpop3/wmpop3
+ dodoc CHANGE_LOG README
+}