summaryrefslogtreecommitdiff
path: root/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild')
-rw-r--r--x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..cb3f20011291
--- /dev/null
+++ b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A dock applet to make any application dockable"
+HOMEPAGE="http://burse.uni-hamburg.de/~friedel/software/wmswallow.html"
+SRC_URI="http://burse.uni-hamburg.de/~friedel/software/wmswallow/${PN}.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/wmswallow
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+ sed -e "s:\${OBJS} -o:\${OBJS} \${LDFLAGS} -o:" \
+ -e "/LIBS/s/-lXext/-lX11 \0/"\
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" xfree
+}
+
+src_install() {
+ dobin wmswallow
+ dodoc CHANGELOG README todo
+}