summaryrefslogtreecommitdiff
path: root/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 02:22:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 02:22:31 +0000
commit3b32ae7547d742f6e65770361188670710bec186 (patch)
tree51b5a45e8291644df70197de17f086e1640e9c7e /x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
parentdd03974882f85ca04e35cfbc97f7ff756f5d5c20 (diff)
gentoo auto-resync : 21:02:2023 - 02:22:31
Diffstat (limited to 'x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild')
-rw-r--r--x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
new file mode 100644
index 000000000000..f1a07a683543
--- /dev/null
+++ b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+MY_PN="vertex-icons"
+EGIT_COMMIT="f27e47edf392596b7967b7d134d3c62ac3fda0c9"
+
+DESCRIPTION="Vertex icon theme"
+HOMEPAGE="https://github.com/horst3180/vertex-icons"
+SRC_URI="https://github.com/horst3180/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
+
+LICENSE="|| ( GPL-3 GPL-2 LGPL-3 CC-BY-SA-3.0 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ default
+ rm COPYING README.md || die
+
+ insinto /usr/share/icons/Vertex
+ doins -r .
+}