summaryrefslogtreecommitdiff
path: root/app-misc/openrgb/openrgb-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/openrgb/openrgb-9999.ebuild')
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild24
1 files changed, 17 insertions, 7 deletions
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 343c012dd241..516276f31fcd 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev
+inherit flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -12,18 +12,17 @@ else
SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
S="${WORKDIR}/OpenRGB-release_${PV}"
KEYWORDS="~amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
fi
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
+DESCRIPTION="Open source RGB lighting control"
HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
LICENSE="GPL-2"
# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
SLOT="0/2"
RDEPEND="
+ dev-cpp/cpp-httplib:=
dev-libs/hidapi
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -34,8 +33,10 @@ RDEPEND="
DEPEND="
${RDEPEND}
dev-cpp/nlohmann_json
+ dev-libs/mdns
"
BDEPEND="
+ dev-qt/linguist-tools:5
virtual/pkgconfig
"
@@ -45,7 +46,8 @@ PATCHES+=(
src_prepare() {
default
- rm -r dependencies/{hidapi,libusb,json,mbedtls}* || die
+ rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
+ || die "Failed to remove unneded deps"
}
src_configure() {
@@ -54,16 +56,22 @@ src_configure() {
# compiles the .cpp file again.
append-ldflags -Wl,--export-dynamic
+ # > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
+ filter-flags -pipe
+
eqmake5 \
INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
- DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
+ DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\"" \
+ LIBS+=-lhttplib
}
src_install() {
emake INSTALL_ROOT="${ED}" install
dodoc README.md OpenRGB.patch
+
udev_dorules 60-openrgb.rules
+ rm -r "${ED}"/usr/lib/udev/ || die
# This is for plugins. Upstream doesn't install any headers at all.
insinto /usr/include/OpenRGB
@@ -71,9 +79,11 @@ src_install() {
}
pkg_postinst() {
+ xdg_icon_cache_update
udev_reload
}
pkg_postrm() {
+ xdg_icon_cache_update
udev_reload
}