summaryrefslogtreecommitdiff
path: root/app-misc
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/Manifest.gzbin49753 -> 49752 bytes
-rw-r--r--app-misc/openrgb-plugin-skin/Manifest2
-rw-r--r--app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild43
-rw-r--r--app-misc/openrgb-plugin-visualmap/Manifest3
-rw-r--r--app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch18
-rw-r--r--app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild47
-rw-r--r--app-misc/openrgb/Manifest6
-rw-r--r--app-misc/openrgb/metadata.xml14
-rw-r--r--app-misc/openrgb/openrgb-0.8.ebuild89
-rw-r--r--app-misc/openrgb/openrgb-9999.ebuild24
10 files changed, 237 insertions, 9 deletions
diff --git a/app-misc/Manifest.gz b/app-misc/Manifest.gz
index d1e6e2b88618..58e7c00a6b30 100644
--- a/app-misc/Manifest.gz
+++ b/app-misc/Manifest.gz
Binary files differ
diff --git a/app-misc/openrgb-plugin-skin/Manifest b/app-misc/openrgb-plugin-skin/Manifest
index 7d9cb1bb8993..2a96b675bda6 100644
--- a/app-misc/openrgb-plugin-skin/Manifest
+++ b/app-misc/openrgb-plugin-skin/Manifest
@@ -1,3 +1,5 @@
+DIST OpenRGBSkinPlugin-release_0.8.tar.bz2 22711 BLAKE2B 25325c6be5cf619940e79e4f431871478e3026188d7aba4b8220a99afda8f75d18ffeafa0f905110d4ce44f5d7e28208f3d7b358cfadfcd4719a22f1ef5cf70d SHA512 89b9a4bcda4600ea7dbd05972bba7c5f8d917606b3def4971e6ccff84d8510ca420747dd85d3395bfea29e62adc775b592f9cbe20a6966776a46e15593f2cf59
DIST openrgbskinplugin-ebb80f7bd0e1efaa995f60454f3c049a4607bc3b.tar.bz2 22843 BLAKE2B 30c88b143b3df829c543744b20424df24bde9dda10f770fb78d653609111801a4d1d3fe16ed3e3c15ad953f41113db5d4da40bc66f7ec57418b2e934cd9a2e32 SHA512 a70c0157072b6b638a5a4f3f48f41c73f422d0ac356174479901cd3d088faf6fe96e594b2a39b15de305e0355fd0d252dafc4a30b9216d57058ad2cde7f5a3e3
+EBUILD openrgb-plugin-skin-0.8.ebuild 966 BLAKE2B 8263ada754a312c3fb34a9510b9630ec4b3de2eadb7baf78b623703e7e4ae64c27e896c6b08ec2b7607341fa67eae1a725404698d2fc8c3efc6a08806435e2c0 SHA512 d616850834306b32b9aacd1e6c5755f5adc0c934a29e5c2c7af31ff7e306ad38d95f06cbd21589ed4996b6da014d3b00be7955e59d6ae686258d9a8fd95e8886
EBUILD openrgb-plugin-skin-0_p20211230.ebuild 1031 BLAKE2B 159cfc98558763303f0709bfa2b86fafe1571edb6aac806c37a76e711220e8b3111a51caea1e76bded0dc6bf97401cf63f8edc14fde78fd50e60f63027383514 SHA512 089258850a1b9b4d6d595358060350a76fc15e7dc8473a587190b1a432d38bb6dc071f28784f9ac7eb5c54ba55f347d76b6e6a11c57368718206080dc8aca124
MISC metadata.xml 481 BLAKE2B f05f1f16d6180b976f0daa79964c7abe5f9f1caee3aa25c1b328916d810438b7e76fd54297412f02c6fd172d6ca754872cd7d28349c328c8ef9cc8af7069a4be SHA512 9a6815da58c1b372a4af82f96484625334c2977a416e902b824d2be17bc7624cf9d1d69f0bc25ce85b833133b81c10e9257f30c825fdeeb230c7ce8772cf4bfd
diff --git a/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild
new file mode 100644
index 000000000000..8a3da828c824
--- /dev/null
+++ b/app-misc/openrgb-plugin-skin/openrgb-plugin-skin-0.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBSkinPlugin/-/archive/release_${PV}/OpenRGBSkinPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBSkinPlugin-release_${PV}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB that allows you to customize the look and feel of OpenRGB"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBSkinPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.8:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBSkinPlugin.so.1.0.0
+}
diff --git a/app-misc/openrgb-plugin-visualmap/Manifest b/app-misc/openrgb-plugin-visualmap/Manifest
index 922f00b81d10..6b13356069bc 100644
--- a/app-misc/openrgb-plugin-visualmap/Manifest
+++ b/app-misc/openrgb-plugin-visualmap/Manifest
@@ -1,3 +1,6 @@
+AUX openrgb-plugin-visualmap-0.8-dep.patch 1318 BLAKE2B 88cc045e917dbc1224bbb7cf105890750e4161ad60acc2466ae2c575e1515a4a836d2b63b6baac9770cbd32e59af9d9ea73f0351778f1091c06e1e5e7dbefd07 SHA512 47f2dab3a0c706eeb5411e762016a19d01e04fd870902fe5fd13fc8cd6000bb5bbe723475ad71555daeb76f62b67ed42389beb2602efba5ea8824c31d90d6bf1
DIST OpenRGBVisualMapPlugin-223c5ec67d256c5fa3bf7f3d572213114d93db6e.tar.bz2 54289 BLAKE2B b42b59fdc31f48d3e7be28051ccb02a2ba1befa1b1ed180a9313c8cbc50bad1c358ab5b4d8f249b488d5f32c801426078ef6c0c3c46dbec9695cb7b7cbf21d40 SHA512 eff52debcd027176a761fba71fb33d4a04802dd8f2441a86a825f3afecb268d2768edb8b03ec35ff2d17b5dc6f95dd0642e7d524fa7fcf93f0d215d712e75f3e
+DIST OpenRGBVisualMapPlugin-release_0.8.tar.bz2 51680 BLAKE2B c3423779f7a2082c8f682b519be2e1128b30dafbc4400414bd664f98de5c58701fbdbe9287a44951e8cf6ac4ee7c940a841f499ee1afce107e17537ad9df076b SHA512 7bf0393bc00bb69545ed02f6505f366aa90bb87350de6319977d02ba0afd38ccb895aa14edf02a42242b0a12f76ea2b135d8de5b3df10469c760b6f3d9dd2b61
+EBUILD openrgb-plugin-visualmap-0.8.ebuild 1028 BLAKE2B 593e22aa931547307e01a4dd4231b126ac8a665db57f216146702f8c93286e291851f3c4d6ee25cab4a9896fbee0fad25baa0b8bfa8ad957372fc34d370b131d SHA512 ae4afb280e8e7ca5eb095437ebbacc03859afd93bf08128c6fd9cdf38f99c26ac2cdb8adc595e5837b39a79544ad5049d769ef8e591a220e05204ebcd3360f9f
EBUILD openrgb-plugin-visualmap-0_p20211230.ebuild 1118 BLAKE2B 8f54089c739a6fb147b306cc3e420604104c5978b3e49e5e4779beadfd46ff0ec681687076cd0252d6f041736f27068d91e9b2f18b0b245a0dae41e92312d701 SHA512 32e7c6e85bb1eed5bb93ae7e68052318f6995627ee648de9f188e0f1455e01d44e3dc7aec2912d7952faa76aa87915f7c764bab9d01901faeef278458f5aa780
MISC metadata.xml 486 BLAKE2B 01cbd7cbe4d88068db283a3eb33d0a23dc100e6effa5d8eea9970c96d75073053ecc161953c0d1ae08b4400c497fc8668004c217b3dde0a3d066f24f9a8f6e7e SHA512 41e51c4089d9e9648656339df9a4ccf52b8907b22da654331b1bd804fb150e0148c1c325e1e15a1f8e2d282f9568f91a31243e9cc9e4aa688d2dfdb75259c5f8
diff --git a/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch
new file mode 100644
index 000000000000..b2023fa1df3a
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/files/openrgb-plugin-visualmap-0.8-dep.patch
@@ -0,0 +1,18 @@
+--- a/OpenRGBVisualMapPlugin.pro
++++ b/OpenRGBVisualMapPlugin.pro
+@@ -96,7 +96,6 @@ HEADERS +=
+ OpenRGB/qt/hsv.h \
+
+ SOURCES += \
+- OpenRGB/RGBController/RGBController.cpp \
+ OpenRGBVisualMapPlugin.cpp \
+ VirtualController.cpp \
+ VisualMapSettingsManager.cpp \
+@@ -120,7 +119,6 @@ SOURCES +=
+ ui/widget-editor/EditorGrid.cpp \
+ ui/widget-editor/LedItem.cpp \
+ ui/widget-editor/WidgetEditor.cpp \
+- OpenRGB/qt/hsv.cpp \
+
+ FORMS += \
+ ui/BackgroundApplier.ui \
diff --git a/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
new file mode 100644
index 000000000000..d6abfbf2af1c
--- /dev/null
+++ b/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/release_${PV}/OpenRGBVisualMapPlugin-release_${PV}.tar.bz2"
+S="${WORKDIR}/OpenRGBVisualMapPlugin-release_${PV}"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
+HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ >=app-misc/openrgb-0.8:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dep.patch"
+)
+
+src_prepare() {
+ default
+ rm -r OpenRGB || die
+ ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
+ sed -e '/^GIT_/d' -i *.pro || die
+}
+
+src_configure() {
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/OpenRGB/plugins
+ doexe libOpenRGBVisualMapPlugin.so.1.0.0
+}
diff --git a/app-misc/openrgb/Manifest b/app-misc/openrgb/Manifest
index 1cbdd59e34ac..68054e1e1302 100644
--- a/app-misc/openrgb/Manifest
+++ b/app-misc/openrgb/Manifest
@@ -4,7 +4,9 @@ AUX OpenRGB-0.7-plugins.patch 1035 BLAKE2B 46025eea33f9cbef73994ea25284e05a7dc18
AUX OpenRGB-0.7-r1-udev.patch 410 BLAKE2B 10e4ba5cc32abed1c5c6bf15426033b03c36929d0d54d247235793193d8e0df26dbd10e1a63edb626a88fbbc5b532f00fac997589afb8885205dad2f53022378 SHA512 0714dc6432fa0d75a8867079d6056f6dc35b98dd62da512643df8649cb2e6bf8de85408485e2b47b2707efef8727789549a216c8adf72447fd084320b1a8e931
AUX OpenRGB-0.7-udev.patch 515 BLAKE2B c535efa9d6fbc5b0f56eb9914ca9c23d3d431f2d98b7d3bdee60bbb0abdb67eb5e21b75be9ec9226e8de1def3136d89175f0500e83ec97b3a23ad1ec1e5929ca SHA512 11c09942811077134c78fd916ab842c39361214888d13187071a2bbf8112f995915b491fd8e8574a5cb59b02d70477ac0ecf42592d433ec24feffe194f7a0534
DIST OpenRGB-release_0.7.tar.bz2 28053114 BLAKE2B dfab42fca654478ab359e6e46133fc20a4bf32aca35d1b2f475d3e4e5e218f35c7e1f03be15381b0e8d874ea24254b88b8fe21548a4183b29b4c66647aeef516 SHA512 6ee605bfc91da14d34bc89fe75790f99548253e2d6aa088e20d1996577629bf15fe0fae09e65d983aa829f54cfcbd33e13f2c7d493a2776fd1723f8725b62186
+DIST OpenRGB-release_0.8.tar.bz2 28631365 BLAKE2B 3b328e38f1c52646da02b0b2b2c22b1285f3b31b0a2bc684e99d491d04bd14a91b49bc196b3b81b537320cd872e5568aaa8aec34744f4f15392d9424a81ac6f0 SHA512 d69686da7cab33099b13cfb5ab876fc2db047f79aa01bf8150507ec41321b4c6c092f81623823b89916c70a1a24c4a102f77b1001c5caa721ff4c0c52e0630d2
EBUILD openrgb-0.7-r1.ebuild 2006 BLAKE2B 953f14e0cc8d84cf10bfcb6a01847498f49c4e3dcfdf364d8f550c74f4c4e05760fa5d43d621b88a04234f544d2de30d0c92ec481a56aea07c5d580436418457 SHA512 691fdbbe73f6cf18644ab30a4843c2bb031519d5b3bcbae6957c38c1b1714280bcb1e9193d677289090707c53e772e136c4158ecf185c757960174db05b6b5e6
EBUILD openrgb-0.7.ebuild 1902 BLAKE2B 9c8a21faeb59e409f2957a05aaa5d86d79caaf32d80ee15720789cc445e6ad87c8d1c4c2d3dca7be2e714e9d69bee6cd0edc7372e1b8f7ab4266fbdc13a2b190 SHA512 adba8992c77da14cdcd8739b4f0d97eb8581edc6756611091c27decab37182aaa64d4d6c265b32aee942a3dcb8a7972857a7b85b6bf3896731f198a0628f8004
-EBUILD openrgb-9999.ebuild 1939 BLAKE2B 999119363bddcbe0841de5d687b8ed90f9a45b2bd100768b36eea83e8df003505d38c69e749e3e3be472b2ac57c942bc2d014c0a3a4c5cde7e9c28cd6c2a0aba SHA512 64795dfb915dbba12a2c9dd1bb97352e452a720896004255e131559fdcf648653a9864525ff2cfe9841421bdd8a0765f7ec9742f6027d465c0e1eaad4fc60ba5
-MISC metadata.xml 469 BLAKE2B 39e7ed78f80bb0d2123efb9c94032ef7df8c514e29528f658f6865ab80f3734e7767108fc787c153dfc0df6c8ffa413fc1fdddb7da25e68cd2537c3d4ddbfe81 SHA512 de37a252c6697a9dacf486e71619b0f5fe895c67d48c55c71233b0082495662120a141cae683206293781b886526e92f0b48c91c30f2a536502cb6bd1e880c9a
+EBUILD openrgb-0.8.ebuild 2207 BLAKE2B a80ad9c6ba5d042101e80941184afd24039cca544c920cfe01919dae874ac99af76fb23dc36c6f5b759c05b577a161823e771dee093d73a252d7c6d280e2e830 SHA512 36dd00491eed7e4fc069c971a44b1e5bf6526da72434ccfba88c092720a9f8d050a09762c6ab464f1ea5a810c5dea50fda3fa95819d8b7e04330a3c1f41d3918
+EBUILD openrgb-9999.ebuild 2207 BLAKE2B a80ad9c6ba5d042101e80941184afd24039cca544c920cfe01919dae874ac99af76fb23dc36c6f5b759c05b577a161823e771dee093d73a252d7c6d280e2e830 SHA512 36dd00491eed7e4fc069c971a44b1e5bf6526da72434ccfba88c092720a9f8d050a09762c6ab464f1ea5a810c5dea50fda3fa95819d8b7e04330a3c1f41d3918
+MISC metadata.xml 1228 BLAKE2B b3844d9c8b09d9d976ee41d874675b179a8e38b1eaaaa06e3052d6bac824dfc8c67102de54d9f62a3f24e4cf0157825608c060a56de2cc21bb71f8c7831148ad SHA512 5067cb355010ada60bfe789a511d02bf3d3a26083544104d782b9c08b0c70457f998c91c71f8d99e48f2d73fef07ea029fcc8c7848bdc5d625f5c1a8c9ca9ca3
diff --git a/app-misc/openrgb/metadata.xml b/app-misc/openrgb/metadata.xml
index 05db5934398f..378bcd2df595 100644
--- a/app-misc/openrgb/metadata.xml
+++ b/app-misc/openrgb/metadata.xml
@@ -5,10 +5,24 @@
<email>chutzpah@gentoo.org</email>
<name>Patrick McLean</name>
</maintainer>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
<maintainer type="person" proxied="yes">
<email>alexey+gentoo@asokolov.org</email>
<name>Alexey Sokolov</name>
</maintainer>
+ <longdescription lang="en">
+ One of the biggest complaints about RGB is the software ecosystem surrounding it.
+ Every manufacturer has their own app, their own brand, their own style.
+ If you want to mix and match devices, you end up with a ton of conflicting,
+ functionally identical apps competing for your background resources.
+ On top of that, these apps are proprietary and Windows-only.
+ Some even require online accounts. What if there was a way to control all of your
+ RGB devices from a single app, on both Windows and Linux, without any nonsense?
+ That is what OpenRGB sets out to achieve. One app to rule them all.
+ </longdescription>
<upstream>
<remote-id type="gitlab">CalcProgrammer1/OpenRGB</remote-id>
</upstream>
diff --git a/app-misc/openrgb/openrgb-0.8.ebuild b/app-misc/openrgb/openrgb-0.8.ebuild
new file mode 100644
index 000000000000..516276f31fcd
--- /dev/null
+++ b/app-misc/openrgb/openrgb-0.8.ebuild
@@ -0,0 +1,89 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic qmake-utils udev xdg-utils
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI=${EGIT_REPO_URI:-"https://gitlab.com/CalcProgrammer1/OpenRGB"}
+else
+ SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
+ S="${WORKDIR}/OpenRGB-release_${PV}"
+ KEYWORDS="~amd64 ~x86"
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
+fi
+
+DESCRIPTION="Open source RGB lighting control"
+HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
+LICENSE="GPL-2"
+# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
+SLOT="0/2"
+
+RDEPEND="
+ dev-cpp/cpp-httplib:=
+ dev-libs/hidapi
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ net-libs/mbedtls:=
+ virtual/libusb:1
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/nlohmann_json
+ dev-libs/mdns
+"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+PATCHES+=(
+ "${FILESDIR}"/OpenRGB-0.7-r1-udev.patch
+)
+
+src_prepare() {
+ default
+ rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
+ || die "Failed to remove unneded deps"
+}
+
+src_configure() {
+ # Some plugins require symbols defined in the main binary.
+ # The official build system bundles OpenRGB as a submodule instead, and
+ # compiles the .cpp file again.
+ append-ldflags -Wl,--export-dynamic
+
+ # > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
+ filter-flags -pipe
+
+ eqmake5 \
+ INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
+ DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\"" \
+ LIBS+=-lhttplib
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install
+
+ dodoc README.md OpenRGB.patch
+
+ udev_dorules 60-openrgb.rules
+ rm -r "${ED}"/usr/lib/udev/ || die
+
+ # This is for plugins. Upstream doesn't install any headers at all.
+ insinto /usr/include/OpenRGB
+ find . -name '*.h' -exec cp --parents '{}' "${ED}/usr/include/OpenRGB/" ';' || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ udev_reload
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ udev_reload
+}
diff --git a/app-misc/openrgb/openrgb-9999.ebuild b/app-misc/openrgb/openrgb-9999.ebuild
index 343c012dd241..516276f31fcd 100644
--- a/app-misc/openrgb/openrgb-9999.ebuild
+++ b/app-misc/openrgb/openrgb-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit flag-o-matic qmake-utils udev
+inherit flag-o-matic qmake-utils udev xdg-utils
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -12,18 +12,17 @@ else
SRC_URI="https://gitlab.com/CalcProgrammer1/OpenRGB/-/archive/release_${PV}/OpenRGB-release_${PV}.tar.bz2"
S="${WORKDIR}/OpenRGB-release_${PV}"
KEYWORDS="~amd64 ~x86"
- PATCHES=(
- "${FILESDIR}"/OpenRGB-0.5-build-system.patch
- )
+ PATCHES=( "${FILESDIR}"/OpenRGB-0.5-build-system.patch )
fi
-DESCRIPTION="Open source RGB lighting control that doesn't depend on manufacturer software"
+DESCRIPTION="Open source RGB lighting control"
HOMEPAGE="https://openrgb.org https://gitlab.com/CalcProgrammer1/OpenRGB/"
LICENSE="GPL-2"
# subslot is OPENRGB_PLUGIN_API_VERSION from https://gitlab.com/CalcProgrammer1/OpenRGB/-/blob/master/OpenRGBPluginInterface.h
SLOT="0/2"
RDEPEND="
+ dev-cpp/cpp-httplib:=
dev-libs/hidapi
dev-qt/qtcore:5
dev-qt/qtgui:5
@@ -34,8 +33,10 @@ RDEPEND="
DEPEND="
${RDEPEND}
dev-cpp/nlohmann_json
+ dev-libs/mdns
"
BDEPEND="
+ dev-qt/linguist-tools:5
virtual/pkgconfig
"
@@ -45,7 +46,8 @@ PATCHES+=(
src_prepare() {
default
- rm -r dependencies/{hidapi,libusb,json,mbedtls}* || die
+ rm -r dependencies/{httplib,hidapi,libusb,mdns,json,mbedtls}* \
+ || die "Failed to remove unneded deps"
}
src_configure() {
@@ -54,16 +56,22 @@ src_configure() {
# compiles the .cpp file again.
append-ldflags -Wl,--export-dynamic
+ # > warning: ‘-pipe’ ignored because ‘-save-temps’ specified
+ filter-flags -pipe
+
eqmake5 \
INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann" \
- DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\""
+ DEFINES+="OPENRGB_EXTRA_PLUGIN_DIRECTORY=\\\\\"\\\"${EPREFIX}/usr/$(get_libdir)/OpenRGB/plugins\\\\\"\\\"" \
+ LIBS+=-lhttplib
}
src_install() {
emake INSTALL_ROOT="${ED}" install
dodoc README.md OpenRGB.patch
+
udev_dorules 60-openrgb.rules
+ rm -r "${ED}"/usr/lib/udev/ || die
# This is for plugins. Upstream doesn't install any headers at all.
insinto /usr/include/OpenRGB
@@ -71,9 +79,11 @@ src_install() {
}
pkg_postinst() {
+ xdg_icon_cache_update
udev_reload
}
pkg_postrm() {
+ xdg_icon_cache_update
udev_reload
}