summaryrefslogtreecommitdiff
path: root/dev-haskell/unicode-data/unicode-data-0.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unicode-data/unicode-data-0.3.0.ebuild')
-rw-r--r--dev-haskell/unicode-data/unicode-data-0.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/unicode-data/unicode-data-0.3.0.ebuild b/dev-haskell/unicode-data/unicode-data-0.3.0.ebuild
new file mode 100644
index 000000000000..816a4b7df3b1
--- /dev/null
+++ b/dev-haskell/unicode-data/unicode-data-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Access Unicode character database"
+HOMEPAGE="https://github.com/composewell/unicode-data"
+HACKAGE_REV="1"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-2.10 )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}