summaryrefslogtreecommitdiff
path: root/dev-haskell/unicode-data
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/unicode-data')
-rw-r--r--dev-haskell/unicode-data/Manifest4
-rw-r--r--dev-haskell/unicode-data/metadata.xml8
-rw-r--r--dev-haskell/unicode-data/unicode-data-0.3.0.ebuild38
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-haskell/unicode-data/Manifest b/dev-haskell/unicode-data/Manifest
new file mode 100644
index 000000000000..b05b7fd6f8b4
--- /dev/null
+++ b/dev-haskell/unicode-data/Manifest
@@ -0,0 +1,4 @@
+DIST unicode-data-0.3.0.cabal 5123 BLAKE2B 9166d0496d890a880d364aae56d48a0d1b6c474a708a8c59754f196f75d07278e8b27d8d0f1f68a6fdab475f039c4b7fa7ca35434efdeb891b016003ef4abb17 SHA512 45ca93bef8197394f5a04528169f269417a915ae550fd8c531826ae85707939666689a2fc33b954ce4cc053330f062fc123ffeae408790f9613181c14db1da05
+DIST unicode-data-0.3.0.tar.gz 142487 BLAKE2B 0e1dbe384957adb0ff53482fe65578a10d6753c3ab14e6e5aa5da60f5891fbe10ce4bd024f76ae5f213b53baef24c1ccf97a4a2cbd79de1595336db23fda64fc SHA512 6e96f9b93f8a37c8e17f6b20fbe5339fdfeeb75a9d0c6311b03e0bdc9a4a6aa87db6adbe2c3d7d4e7671635df1b32c5325d37815f48ae03ab3b27190a293896b
+EBUILD unicode-data-0.3.0.ebuild 993 BLAKE2B 14d0fa73d7905faf847c973714b3d5b2926b61f60eb0c4686ff489697f970503e7261561bd6191dea6baa52f76c3afe97965766844e34ad7564cbc3c1bbeb583 SHA512 1b5f051f7902361ede01a785d985ea949c2fc2d27258069862a0f486b390dc1469f0fd6e79ad3428507c3e015d523f2a6377a44709afd8d6e1cb4d6399e8716a
+MISC metadata.xml 249 BLAKE2B 84b809c265ff2a09d1f06c66d4797652ff4c64205d94323e07333ae0fbddcfb8c58d0176a8cc52bd37e9353371d987b9b473b9747cb082e1c2871ed80fcfa144 SHA512 ce055b41ff1c10209e88579fe21ce16550be7e9b21f87724564f06430aa6f478974f186a10c8ff7e92398f534c09109aeed57eae1c6d2b56b5c99ebfb64a0015
diff --git a/dev-haskell/unicode-data/metadata.xml b/dev-haskell/unicode-data/metadata.xml
new file mode 100644
index 000000000000..b7878815d80d
--- /dev/null
+++ b/dev-haskell/unicode-data/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-haskell/unicode-data/unicode-data-0.3.0.ebuild b/dev-haskell/unicode-data/unicode-data-0.3.0.ebuild
new file mode 100644
index 000000000000..816a4b7df3b1
--- /dev/null
+++ b/dev-haskell/unicode-data/unicode-data-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Access Unicode character database"
+HOMEPAGE="https://github.com/composewell/unicode-data"
+HACKAGE_REV="1"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
+ https://hackage.haskell.org/package/${P}/revision/${HACKAGE_REV}.cabal -> ${PF}.cabal"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.4.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2.0 <dev-haskell/hspec-2.10 )
+"
+BDEPEND="app-text/dos2unix"
+
+src_prepare() {
+ # pull revised cabal from upstream
+ cp "${DISTDIR}/${PF}.cabal" "${S}/${PN}.cabal" || die
+
+ # Convert to unix line endings
+ dos2unix "${S}/${PN}.cabal" || die
+
+ # Apply patches *after* pulling the revised cabal
+ default
+}