summaryrefslogtreecommitdiff
path: root/dev-python/python-hpilo/python-hpilo-4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-hpilo/python-hpilo-4.0.ebuild')
-rw-r--r--dev-python/python-hpilo/python-hpilo-4.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/python-hpilo/python-hpilo-4.0.ebuild b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
new file mode 100644
index 000000000000..a291d1ad427b
--- /dev/null
+++ b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="iLO automation from python or shell"
+HOMEPAGE="https://pypi.python.org/pypi/python-hpilo"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ ${EPYTHON} -m unittest discover || die
+}