summaryrefslogtreecommitdiff
path: root/dev-python/python-hpilo
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-hpilo')
-rw-r--r--dev-python/python-hpilo/Manifest5
-rw-r--r--dev-python/python-hpilo/metadata.xml19
-rw-r--r--dev-python/python-hpilo/python-hpilo-3.9.ebuild21
-rw-r--r--dev-python/python-hpilo/python-hpilo-4.0.ebuild21
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/python-hpilo/Manifest b/dev-python/python-hpilo/Manifest
new file mode 100644
index 000000000000..514911fa1fda
--- /dev/null
+++ b/dev-python/python-hpilo/Manifest
@@ -0,0 +1,5 @@
+DIST python-hpilo-3.9.tar.gz 177570 BLAKE2B 7442871e1d1d82010cb2ec6c2ff947fe2cd1b627a9920cd0fa6260f3efb4c85bc44d6fce7a0b967f3cd54cb1626f454584abab963eade9d6e7b67088114ce4fe SHA512 777b3d1f93da196e57b1359d6d5024c60d28d2ed88bc8e84c883aabcd3bfa68ace989b9a22975fe09279957b070a11637b5d943e923c6827eb29466d62cbdad5
+DIST python-hpilo-4.0.tar.gz 178109 BLAKE2B aa8d4f9f74c053cb65d6c1ae77602a045923250aa9e4e3d689aa305094bb91a3a100a365d28fbb5fb0b69887d27a00796ffa2d9ff9f5eb26800f18672f73a6c6 SHA512 5a084899275b169a753d93b599c6b0d4d46d695c1378bbea340740d9e654723ff44e85cb71213c2e6811356d826e3912598b18f0f1aaeb906f19b0fc3064fbde
+EBUILD python-hpilo-3.9.ebuild 485 BLAKE2B 82787326f5c310227034ba4560c6a6c17c06cf135c5ac7178edfad1f874a3a0ee8592de7b344d1dc6d8a81784650f6acdeac7d2f66e12326a2c804a641b50940 SHA512 001332261aef59488b46cf2930cdedcc208633a1ec6309651f48cdf00b04252677d8d933e2e885b38578d4a836c1751d917c43705fe5cb8fc70377d08bc1eb92
+EBUILD python-hpilo-4.0.ebuild 485 BLAKE2B 82787326f5c310227034ba4560c6a6c17c06cf135c5ac7178edfad1f874a3a0ee8592de7b344d1dc6d8a81784650f6acdeac7d2f66e12326a2c804a641b50940 SHA512 001332261aef59488b46cf2930cdedcc208633a1ec6309651f48cdf00b04252677d8d933e2e885b38578d4a836c1751d917c43705fe5cb8fc70377d08bc1eb92
+MISC metadata.xml 666 BLAKE2B aae5ef2572734016e24e84795420e0f8083b2c5bbb8357a49b1d90d0d273701c311c5feeb9df7f9141236f4c2eafbd8a708b01d79e1f2fc9e87244f93046ab15 SHA512 e177656c862474bdfc61bbd01fa3f2a06f4d136594491a9156c95082671066eaa7c00b570cdc0a6ae550ee6d98f62fc2569fa9129d66cfd9c8b3d1825d050928
diff --git a/dev-python/python-hpilo/metadata.xml b/dev-python/python-hpilo/metadata.xml
new file mode 100644
index 000000000000..ab62601285cf
--- /dev/null
+++ b/dev-python/python-hpilo/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>nicolasbock@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ HP servers come with a powerful out of band management
+ interface called Integrated Lights out, or iLO. It has an
+ extensive web interface and commercially available tools for
+ centrally managing iLO devices and their servers.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">seveas/python-hpilo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-hpilo/python-hpilo-3.9.ebuild b/dev-python/python-hpilo/python-hpilo-3.9.ebuild
new file mode 100644
index 000000000000..a291d1ad427b
--- /dev/null
+++ b/dev-python/python-hpilo/python-hpilo-3.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="iLO automation from python or shell"
+HOMEPAGE="https://pypi.python.org/pypi/python-hpilo"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ ${EPYTHON} -m unittest discover || die
+}
diff --git a/dev-python/python-hpilo/python-hpilo-4.0.ebuild b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
new file mode 100644
index 000000000000..a291d1ad427b
--- /dev/null
+++ b/dev-python/python-hpilo/python-hpilo-4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="iLO automation from python or shell"
+HOMEPAGE="https://pypi.python.org/pypi/python-hpilo"
+SRC_URI="https://github.com/seveas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+ ${EPYTHON} -m unittest discover || die
+}