summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild')
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild
new file mode 100644
index 000000000000..abea757ccd1d
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-4.0.0
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ kde-frameworks/kwindowsystem:6
+ >=kde-plasma/layer-shell-qt-6.0:6
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"