summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-notificationd
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-notificationd')
-rw-r--r--lxqt-base/lxqt-notificationd/Manifest2
-rw-r--r--lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-notificationd/Manifest b/lxqt-base/lxqt-notificationd/Manifest
index d782cfaf00a6..d242a826e1c2 100644
--- a/lxqt-base/lxqt-notificationd/Manifest
+++ b/lxqt-base/lxqt-notificationd/Manifest
@@ -1,5 +1,7 @@
DIST lxqt-notificationd-1.3.0.tar.xz 61064 BLAKE2B 249a2cd764cb8ca0bbd4de1bb903df87b58d1efe6cab775edc60dfd4ac6da7bac4f83fad95d3567df7fd4adb3a0a06372fbd70b44a71a4e40b03dfdd3a062710 SHA512 8bc57c8a6710aaa5d050802a588530ec446611362eaa7c87aae2dae74b7ed9745486a90efbd854dedf79bc9994e13b5444f8b5259452614e01a8b393dd796607
DIST lxqt-notificationd-1.4.0.tar.xz 61792 BLAKE2B e44c9e80c9fb964547902d242ea0cb5967977e4e9dad1c047daae8dadd105f97fd1cd30c5022511d9ece3c3f1e6fbf74ef79e2a5df2e2725603d3d1151dfb166 SHA512 5ae28b0f49e1e01c8d0fe96f23b961ca962dab33f16025af172777f385d0fd3471c64a7acb78b46e7dc0c370d324a17f10ec9a4c4b3afbde95d47164a5246d0a
+DIST lxqt-notificationd-2.0.1.tar.xz 64132 BLAKE2B 55d0c7f785528acde181161c0d0c4f61f952700f90e535d00ab7009d768f8118e54a6ab10a75e3e3dda2def4fc395720de89701e4fc3ec0927aa9bd346c7723c SHA512 c2a532e61129f09dde253f7499485f85088c19f8cc6f5ddfd1949eb9d43b142ee4f3f526b38a70fbe276623c1637398c70470f24bcdbb5597a499354e9840d67
EBUILD lxqt-notificationd-1.3.0.ebuild 811 BLAKE2B 30b86a2d9aca48f41b201efcd90c5cff22883dbcf4f957384cb562111bcbdabcd8ec20f6102b855e014a07ec6489b68416045e30f3f24e667e322aac9ce88f92 SHA512 6d30d9e225bc7f651cc0e9f83ae6e0f5c891e3bc784fd5b6e6275500a517381ff00ec0c865af36598df1820c576fe61dcdc46f7576d9336de53207857fbf822a
EBUILD lxqt-notificationd-1.4.0.ebuild 811 BLAKE2B 43b5d246d67a707bf500eb6abc9f39ba938f3171ed9c3271f43d058e80f1da65926d0b3cd2fb831219307c44660e7873ec19141836da3f4e651b8a7835f07e00 SHA512 7ca301caa0c1af746e2c1dc8acb045b3a9c941d1aaf967f533264a6a37b348b416dd1884b7eea0b6f897e6a43e629b803a299b28632ba7a02dc2efda293c2a94
+EBUILD lxqt-notificationd-2.0.1.ebuild 760 BLAKE2B 53abb60e528fec15079f9b6439c4e2175a71f2bbe437bac273b3d439d9cc10c7e658c6ae6f8c887715f85abf7c34285e428f7ed1ec8a31655655bba5e87a5aa9 SHA512 2c833f407c3368b2e6dd060463c674d08f4fead143aff23d1a1511f55b5ac257d611d28edc17b312de4cea861b9899b5fddb9e21ab8eaca289cac206ddddb26b
MISC metadata.xml 324 BLAKE2B 9a9ade6923097018d9e6caa51617b06c04df45227a4afbf512e04a54e2e5387f162c9b48483ff0f2fa9451a118f8b372bd1d3a487a0be2f3c896524611fe97c6 SHA512 252b5a4a24e16a6cc461670adafccb7041a8229414bd68e564ceadab8bd1ee7141fc43d8db9b6a04c161c947749c28e21815d40f49f44ea049a23167d408368f
diff --git a/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild
new file mode 100644
index 000000000000..abea757ccd1d
--- /dev/null
+++ b/lxqt-base/lxqt-notificationd/lxqt-notificationd-2.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt notification daemon and library"
+HOMEPAGE="https://lxqt-project.org/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ >=dev-libs/libqtxdg-4.0.0
+ >=dev-qt/qtbase-6.6:6[dbus,gui,widgets]
+ kde-frameworks/kwindowsystem:6
+ >=kde-plasma/layer-shell-qt-6.0:6
+ =lxqt-base/liblxqt-${MY_PV}*:=
+"
+RDEPEND="${DEPEND}"